summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-04 00:03:26 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-04 00:06:46 +0300
commit64603e31ebfe443cc406a88b4347f5a96ff2d83e (patch)
treefeef3a9824d6a7583b7cf1c5423c8edc64d0d0cf /app-metrics/prometheus
parentsys-boot/plymouth: Drop 0.9.3-r1, EAPI6-- (diff)
downloadgentoo-64603e31ebfe443cc406a88b4347f5a96ff2d83e.tar.gz
gentoo-64603e31ebfe443cc406a88b4347f5a96ff2d83e.tar.bz2
gentoo-64603e31ebfe443cc406a88b4347f5a96ff2d83e.zip
app-metrics/prometheus: use promu for building (again)
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-metrics/prometheus')
-rw-r--r--app-metrics/prometheus/prometheus-2.26.0-r2.ebuild (renamed from app-metrics/prometheus/prometheus-2.26.0-r1.ebuild)12
1 files changed, 5 insertions, 7 deletions
diff --git a/app-metrics/prometheus/prometheus-2.26.0-r1.ebuild b/app-metrics/prometheus/prometheus-2.26.0-r2.ebuild
index a8109672d3a4..c6e3e6c97398 100644
--- a/app-metrics/prometheus/prometheus-2.26.0-r1.ebuild
+++ b/app-metrics/prometheus/prometheus-2.26.0-r2.ebuild
@@ -1356,6 +1356,8 @@ DEPEND="!app-metrics/prometheus-bin
RDEPEND="${COMMON_DEPEND}"
+BDEPEND=">=dev-util/promu-0.3.0"
+
RESTRICT+=" test"
src_prepare() {
@@ -1364,16 +1366,12 @@ src_prepare() {
}
src_compile() {
- # no need in promu here
-
- go build -mod=readonly -tags builtinassets ./cmd/prometheus || die
-
- go build -mod=readonly ./cmd/promtool || die
+ promu build --prefix bin -v || die
}
src_install() {
- dobin "${S}"/prometheus
- dobin "${S}"/promtool
+ dobin "${S}"/bin/prometheus
+ dobin "${S}"/bin/promtool
dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
insinto /etc/prometheus
doins documentation/examples/prometheus.yml