summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2018-06-16 16:00:56 +0200
committerManuel Rüger <mrueg@gentoo.org>2018-06-16 16:00:56 +0200
commitf1b8e15de61579c83b8247339cb45f55d71320cb (patch)
tree645ccfbf830b5e76211b946292d7578a36c69fb4 /app-metrics/pushgateway/pushgateway-0.5.2.ebuild
parentdev-db/etcd: Version bump to 3.3.8 (diff)
downloadgentoo-f1b8e15de61579c83b8247339cb45f55d71320cb.tar.gz
gentoo-f1b8e15de61579c83b8247339cb45f55d71320cb.tar.bz2
gentoo-f1b8e15de61579c83b8247339cb45f55d71320cb.zip
app-metrics/pushgateway: Version bump to 0.5.2
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-metrics/pushgateway/pushgateway-0.5.2.ebuild')
-rw-r--r--app-metrics/pushgateway/pushgateway-0.5.2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/app-metrics/pushgateway/pushgateway-0.5.2.ebuild b/app-metrics/pushgateway/pushgateway-0.5.2.ebuild
new file mode 100644
index 000000000000..48c3741c2232
--- /dev/null
+++ b/app-metrics/pushgateway/pushgateway-0.5.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot systemd
+
+EGO_PN="github.com/prometheus/pushgateway"
+EGIT_COMMIT="v${PV/_rc/-rc.}"
+GIT_COMMIT="231071b"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus push acceptor for ephemeral and batch jobs"
+HOMEPAGE="https://github.com/prometheus/pushgateway"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 -1 ${PN}
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${GIT_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ mkdir -p bin || die
+ GOPATH="${S}" promu build -v --prefix bin || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin bin/pushgateway
+ dodoc {README,CHANGELOG,CONTRIBUTING}.md
+ popd || die
+ keepdir /var/lib/${PN} /var/log/${PN}
+ fowners ${PN}:${PN} /var/lib/${PN} /var/log/${PN}
+ newinitd "${FILESDIR}"/${PN}-1.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}-1.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}-1.service"
+}