summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2021-05-03 17:27:53 -0500
committerWilliam Hubbs <williamh@gentoo.org>2021-05-03 17:37:50 -0500
commit13b2d4a97078e21b981c0c0ed1e9ad1952fc78ac (patch)
tree753297d617a4d619c5de5f389c58063507437b03 /app-metrics
parentmedia-libs/freeglut: Revbump (diff)
downloadgentoo-13b2d4a97078e21b981c0c0ed1e9ad1952fc78ac.tar.gz
gentoo-13b2d4a97078e21b981c0c0ed1e9ad1952fc78ac.tar.bz2
gentoo-13b2d4a97078e21b981c0c0ed1e9ad1952fc78ac.zip
app-metrics/blackbox_exporter: 0.18.2 rev bump
- clean up binary renaming - disable tests (they require the network) Closes: https://bugs.gentoo.org/701232 Closes: https://bugs.gentoo.org/731006 Closes: https://bugs.gentoo.org/781869 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/blackbox_exporter/blackbox_exporter-0.18.0-r2.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-metrics/blackbox_exporter/blackbox_exporter-0.18.0-r2.ebuild b/app-metrics/blackbox_exporter/blackbox_exporter-0.18.0-r2.ebuild
new file mode 100644
index 000000000000..f91c8f04e991
--- /dev/null
+++ b/app-metrics/blackbox_exporter/blackbox_exporter-0.18.0-r2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit fcaps go-module systemd
+GIT_COMMIT=1bc7680
+MY_PV="v${PV/_rc/-rc.}"
+
+DESCRIPTION="Prometheus exporter for blackbox probing via HTTP, HTTPS, DNS, TCP and ICMP"
+HOMEPAGE="https://github.com/prometheus/blackbox_exporter"
+SRC_URI="https://github.com/prometheus/blackbox_exporter/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-util/promu"
+
+DEPEND="
+ acct-group/blackbox_exporter
+ acct-user/blackbox_exporter"
+
+FILECAPS=(
+ cap_net_raw usr/bin/blackbox_exporter
+)
+
+# tests require the network
+restrict+=" test "
+src_prepare() {
+ default
+ sed -i \
+ -e "s/{{.Branch}}/Head/" \
+ -e "s/{{.Revision}}/${GIT_COMMIT}/" \
+ -e "s/{{.Revision}}/${PV}/" .promu.yml || die
+}
+
+src_compile() {
+ promu build -v --prefix bin || die
+}
+
+src_install() {
+ dobin bin/*
+ dodoc {README,CONFIGURATION}.md blackbox.yml
+ insinto /etc/blackbox_exporter
+ newins example.yml blackbox.yml
+ keepdir /var/lib/blackbox_exporter /var/log/blackbox_exporter
+ fowners ${PN}:${PN} /var/lib/blackbox_exporter /var/log/blackbox_exporter
+ systemd_dounit "${FILESDIR}"/blackbox_exporter.service
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}/${PN}.logrotated" "${PN}"
+}