summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2020-05-27 14:20:09 +0300
committerAlexey Shvetsov <alexxy@gentoo.org>2020-05-27 14:20:20 +0300
commit17a913b066ba5750abc500964b9aaed5b227ece4 (patch)
treecc09c488f5ac6b856af158f8eadc4321298c646f /app-metrics
parentdev-python/jaraco-envs: Remove broken setuptools_scm removal (diff)
downloadgentoo-17a913b066ba5750abc500964b9aaed5b227ece4.tar.gz
gentoo-17a913b066ba5750abc500964b9aaed5b227ece4.tar.bz2
gentoo-17a913b066ba5750abc500964b9aaed5b227ece4.zip
app-metrics/fusioninventory-agent: Fix agent daemon startup
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Alexey Shvetsov <alexxy@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch44
-rw-r--r--app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild1
2 files changed, 31 insertions, 14 deletions
diff --git a/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch b/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
index e37b58c43a0c..a3a6b439713c 100644
--- a/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
+++ b/app-metrics/fusioninventory-agent/files/fusioninventory-agent-2.5.2-dirs.patch
@@ -1,5 +1,33 @@
---- a/Makefile.PL 2020-05-27 02:16:42.106531746 +0300
-+++ b/Makefile.PL 2020-05-27 02:17:30.568531767 +0300
+diff -urN a/lib/FusionInventory/Agent/Config.pm b/lib/FusionInventory/Agent/Config.pm
+--- a/lib/FusionInventory/Agent/Config.pm 2020-05-27 11:09:31.969999393 -0000
++++ b/lib/FusionInventory/Agent/Config.pm 2020-05-27 11:09:39.833332729 -0000
+@@ -67,7 +67,7 @@
+ my ($class, %params) = @_;
+
+ my $self = {
+- '_confdir' => undef, # SYSCONFDIR replaced here from Makefile
++ '_confdir' => '/etc/fusioninventory', # SYSCONFDIR replaced here from Makefile
+ };
+ bless $self, $class;
+ $self->_loadDefaults();
+diff -urN a/lib/setup.pm b/lib/setup.pm
+--- a/lib/setup.pm 2020-05-27 11:09:31.989999393 -0000
++++ b/lib/setup.pm 2020-05-27 11:11:02.233332727 -0000
+@@ -11,9 +11,9 @@
+ our @EXPORT = ('%setup');
+
+ our %setup = (
+- datadir => './share',
++ datadir => '/usr/share/fusioninventory',
+ libdir => './lib',
+- vardir => './var',
++ vardir => '/var/lib/fusioninventory',
+ );
+
+ # Compute directly libdir from this setup file as it should be installed
+diff -urN a/Makefile.PL b/Makefile.PL
+--- a/Makefile.PL 2020-05-27 11:09:31.966666059 -0000
++++ b/Makefile.PL 2020-05-27 11:09:39.833332729 -0000
@@ -170,18 +170,15 @@
INSTALLSCRIPT => '$(PREFIX)/bin',
INSTALLSITESCRIPT => '$(PREFIX)/bin',
@@ -21,15 +49,3 @@
);
# allow variables defined on command line to override defaults
---- a/lib/FusionInventory/Agent/Config.pm 2020-05-27 10:06:21.248964808 +0300
-+++ b/lib/FusionInventory/Agent/Config.pm 2020-05-27 10:06:57.324964823 +0300
-@@ -67,7 +67,7 @@
- my ($class, %params) = @_;
-
- my $self = {
-- '_confdir' => undef, # SYSCONFDIR replaced here from Makefile
-+ '_confdir' => '/etc/fusioninventory', # SYSCONFDIR replaced here from Makefile
- };
- bless $self, $class;
- $self->_loadDefaults();
-
diff --git a/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild b/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild
index 9b0a5d9d145c..50d906752ad4 100644
--- a/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild
+++ b/app-metrics/fusioninventory-agent/fusioninventory-agent-2.5.2.ebuild
@@ -21,6 +21,7 @@ DEPEND="
dev-perl/Text-Template
dev-perl/UNIVERSAL-require
dev-perl/XML-TreePP
+ dev-perl/XML-XPath
virtual/perl-IO-Compress
dev-perl/HTTP-Daemon
dev-perl/IO-Socket-SSL