summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2021-05-19 15:44:43 +0300
committerMikle Kolyada <zlogene@gentoo.org>2021-05-19 15:45:52 +0300
commit47907bb7cb0eeef8ea6b11e2fad7c19dbd1066f0 (patch)
tree32f566ab95a01b2b2b732d370efec2ededb68caa /app-metrics
parentapp-metrics/prometheus-bin: Drop old (diff)
downloadgentoo-47907bb7cb0eeef8ea6b11e2fad7c19dbd1066f0.tar.gz
gentoo-47907bb7cb0eeef8ea6b11e2fad7c19dbd1066f0.tar.bz2
gentoo-47907bb7cb0eeef8ea6b11e2fad7c19dbd1066f0.zip
app-metrics/prometheus-bin: Version bump (v2.27.1)
Package-Manager: Portage-3.0.17, Repoman-3.0.2 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus-bin/Manifest1
-rw-r--r--app-metrics/prometheus-bin/prometheus-bin-2.27.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/app-metrics/prometheus-bin/Manifest b/app-metrics/prometheus-bin/Manifest
index 2ec60a169e0a..9111183e3c56 100644
--- a/app-metrics/prometheus-bin/Manifest
+++ b/app-metrics/prometheus-bin/Manifest
@@ -1,2 +1,3 @@
DIST prometheus-2.26.1.linux-amd64.tar.gz 65179092 BLAKE2B 631dfbaf9d8553297bd763b2a1ce7cb97d66ec90bff126466868a59b0a0fe074fc13866e2c99f085c7257c3047ab4105f16508c1397de76a1420b4df0b203455 SHA512 53cbbef86204973a01e0d20b287cdbe2c1743dc2add0449d10da55dd3fbed95eaa5beb0a2cd08b4a33fb1825440c91633ef7680616d89838868216fafcd27c55
DIST prometheus-2.27.0.linux-amd64.tar.gz 69496978 BLAKE2B 73c343c21b885382441d200aa42327d30446f0d577dc6875b8c8bad44cbafcf54868e3ee60aaa01273a1c8a53a94eef02477d3ffc1a33fbc08b0e65b6d45355d SHA512 6771211abc5c4ad78ef7243e8920cf57e17eaaa19496b72f634175e911b61597ed8e0c70ef88a82fb727b75bda6e4393b13d0950bfb6073feb0a0ef5352712b0
+DIST prometheus-2.27.1.linux-amd64.tar.gz 69491886 BLAKE2B 7739bd6d84570d4d0db987a0b027ba875728245ded5fac17f89adddfd9b14543cd9594664a8d42392a7a018477ece69ac47367f03442c0f5b11a1e76140ad7c6 SHA512 df43385e178f698806181ab67db0b75600d356c7792f2dcfe6e3390a8a7b449f180ea8fccbc58c10ad0118cea1ba8d5664676de9741e5f91a1a4ec897baeb88f
diff --git a/app-metrics/prometheus-bin/prometheus-bin-2.27.1.ebuild b/app-metrics/prometheus-bin/prometheus-bin-2.27.1.ebuild
new file mode 100644
index 000000000000..da63a8595d37
--- /dev/null
+++ b/app-metrics/prometheus-bin/prometheus-bin-2.27.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit systemd
+
+DESCRIPTION="prometheus monitoring system and time series database"
+HOMEPAGE="https://prometheus.io"
+MY_PN=${PN%%-bin}
+MY_P=${MY_PN}-${PV}
+SRC_URI="https://github.com/prometheus/prometheus/releases/download/v${PV}/${MY_P}.linux-amd64.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+QA_PREBUILT=".*"
+RESTRICT="strip"
+
+DEPEND="acct-group/prometheus
+ acct-user/prometheus
+ !app-metrics/prometheus"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}.linux-amd64"
+
+src_install() {
+ dobin prometheus promtool
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ insinto /etc/prometheus
+ doins prometheus.yml
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+
+ systemd_dounit "${FILESDIR}"/prometheus.service
+ newinitd "${FILESDIR}"/prometheus.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}