summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2020-12-21 13:53:15 +0000
committerMarek Szuba <marecki@gentoo.org>2020-12-21 13:56:49 +0000
commit479b77e4b17c6bf2ae1a88a0f54ff91b14c106b8 (patch)
tree539df320168929dcf20515f4c1e1fd5b4d28a899 /app-metrics
parentapp-emulation/s6-overlay: Bump to version 2.1.0.2 (diff)
downloadgentoo-479b77e4b17c6bf2ae1a88a0f54ff91b14c106b8.tar.gz
gentoo-479b77e4b17c6bf2ae1a88a0f54ff91b14c106b8.tar.bz2
gentoo-479b77e4b17c6bf2ae1a88a0f54ff91b14c106b8.zip
app-metrics/nginx-lua-prometheus: migrate to lua-single.eclass
Pure-Lua module - but not really multi-impl because being used internally by nginx, it must only be available for the LUA_SINGLE_TARGET of the latter. Closes: https://bugs.gentoo.org/752561 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610-r100.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610-r100.ebuild b/app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610-r100.ebuild
new file mode 100644
index 000000000000..cd6f311c9ea0
--- /dev/null
+++ b/app-metrics/nginx-lua-prometheus/nginx-lua-prometheus-0.1_pre20170610-r100.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# This should be kept in sync with implementations supported
+# by www-servers/nginx
+LUA_COMPAT=( luajit )
+
+# This is the upstream tag which corresponds to this release.
+# It needs to be updated with every bump.
+TAG="0.1-20170610"
+
+inherit lua-single
+
+DESCRIPTION="Library that exports Nginx metrics to Prometheus"
+HOMEPAGE="https://github.com/knyar/nginx-lua-prometheus"
+SRC_URI="https://github.com/knyar/${PN}/archive/${TAG}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+COMMON_DEPEND="${LUA_DEPS}"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}
+ www-servers/nginx[nginx_modules_http_lua,${LUA_SINGLE_USEDEP}]"
+BDEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${TAG}"
+
+src_install() {
+ insinto "$(lua_get_lmod_dir)"/${PN}
+ doins prometheus.lua
+ dodoc *.md
+}