summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2023-03-27 17:00:44 -0500
committerWilliam Hubbs <williamh@gentoo.org>2023-03-27 17:00:44 -0500
commit9d5ea8a4db03baefcbd382952f42cc8cbe382809 (patch)
tree728e2c25533d69b73ad44f585e9bf325349e8fab /app-metrics
parentnet-misc/oidc-agent: 4.5.1: pass USE_SO vars to all emake calls (diff)
downloadgentoo-9d5ea8a4db03baefcbd382952f42cc8cbe382809.tar.gz
gentoo-9d5ea8a4db03baefcbd382952f42cc8cbe382809.tar.bz2
gentoo-9d5ea8a4db03baefcbd382952f42cc8cbe382809.zip
app-metrics/prometheus: fix cp in prepare phase
The cp call needs to use -u instead of -n to work with >=coreutils-9.2. Closes: https://bugs.gentoo.org/902751 Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'app-metrics')
-rw-r--r--app-metrics/prometheus/prometheus-2.43.0-r2.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-metrics/prometheus/prometheus-2.43.0-r2.ebuild b/app-metrics/prometheus/prometheus-2.43.0-r2.ebuild
index db5a914685b6..ff0cb6c8462d 100644
--- a/app-metrics/prometheus/prometheus-2.43.0-r2.ebuild
+++ b/app-metrics/prometheus/prometheus-2.43.0-r2.ebuild
@@ -38,7 +38,7 @@ src_prepare() {
-e "s/{{.Revision}}/${GIT_COMMIT}/" \
-e "s/{{.Version}}/${PV}/" \
.promu.yml || die
- cp -a -n "${WORKDIR}"/web/ui web || die
+ cp -a -u "${WORKDIR}"/web/ui web || die "cp failed"
}
src_compile() {