summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2018-02-16 22:13:18 +1100
committerMichael Palimaka <kensington@gentoo.org>2018-02-16 22:13:27 +1100
commitbfb2f0bec5cfc141e1ce8a8e9b7211a5f33e76a8 (patch)
treed2485613f1ac24daddeef403d3ab4699d4966432 /app-misc/asciinema/asciinema-2.0.0.ebuild
parentdev-util/gource: version bump 0.48 (diff)
downloadgentoo-bfb2f0bec5cfc141e1ce8a8e9b7211a5f33e76a8.tar.gz
gentoo-bfb2f0bec5cfc141e1ce8a8e9b7211a5f33e76a8.tar.bz2
gentoo-bfb2f0bec5cfc141e1ce8a8e9b7211a5f33e76a8.zip
app-misc/asciinema: version bump 2.0.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'app-misc/asciinema/asciinema-2.0.0.ebuild')
-rw-r--r--app-misc/asciinema/asciinema-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-misc/asciinema/asciinema-2.0.0.ebuild b/app-misc/asciinema/asciinema-2.0.0.ebuild
new file mode 100644
index 000000000000..802f14de7615
--- /dev/null
+++ b/app-misc/asciinema/asciinema-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Command line recorder for asciinema.org service"
+HOMEPAGE="https://asciinema.org/ https://pypi.python.org/pypi/asciinema"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+"
+
+DOCS=( CHANGELOG.md CONTRIBUTING.md README.md doc/asciicast-v1.md )
+
+python_test() {
+ nosetests || die
+}
+
+src_install() {
+ distutils-r1_src_install
+ doman man/asciinema.1
+}