summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-29 10:29:57 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-29 16:10:06 -0400
commit7634da65f4c569a4f2f4dcc63cb9ab39132b585e (patch)
tree5fa0c9683ba6a2eed9041fa2fd350535bbeebe49 /app-misc/binclock/binclock-1.5.ebuild
parentapp-emulation/coldfire: bump EAPI and drop eutils (diff)
downloadgentoo-7634da65f4c569a4f2f4dcc63cb9ab39132b585e.tar.gz
gentoo-7634da65f4c569a4f2f4dcc63cb9ab39132b585e.tar.bz2
gentoo-7634da65f4c569a4f2f4dcc63cb9ab39132b585e.zip
app-misc/binclock: bump EAPI and drop eutils
This also moves the sed call to a patch for the Makefile. Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'app-misc/binclock/binclock-1.5.ebuild')
-rw-r--r--app-misc/binclock/binclock-1.5.ebuild21
1 files changed, 10 insertions, 11 deletions
diff --git a/app-misc/binclock/binclock-1.5.ebuild b/app-misc/binclock/binclock-1.5.ebuild
index 3e80505179b1..0c4db18b0aad 100644
--- a/app-misc/binclock/binclock-1.5.ebuild
+++ b/app-misc/binclock/binclock-1.5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Displays a binary clock in your terminal"
HOMEPAGE="http://www.ngolde.de/binclock/"
@@ -17,16 +17,15 @@ IUSE=""
RDEPEND=""
DEPEND=">=sys-apps/sed-4"
-src_prepare() {
- sed -i -e s/strip/true/ Makefile || die
-}
+PATCHES=( "${FILESDIR}/binclock-1.5-Makefile.patch" )
-src_compile() {
- emake CC="$(tc-getCC)" CFLAGS="${CFLAGS} ${LDFLAGS}" || die "emake failed"
+src_configure() {
+ append-cflags -Wall -pedantic
+ tc-export CC
}
src_install() {
- dobin binclock || die "dobin failed"
- doman doc/binclock.1 || die "doman failed"
- dodoc CHANGELOG README binclockrc || die "dodoc failed"
+ dobin binclock
+ doman doc/binclock.1
+ dodoc CHANGELOG README binclockrc
}