summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/binwalk/files/binwalk-2.0.1-makefile.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/binwalk/files/binwalk-2.0.1-makefile.patch')
-rw-r--r--app-misc/binwalk/files/binwalk-2.0.1-makefile.patch61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/binwalk/files/binwalk-2.0.1-makefile.patch b/app-misc/binwalk/files/binwalk-2.0.1-makefile.patch
new file mode 100644
index 000000000000..e70f096ea6b4
--- /dev/null
+++ b/app-misc/binwalk/files/binwalk-2.0.1-makefile.patch
@@ -0,0 +1,61 @@
+Don't build python via the makefile and fix parallel make jobs.
+
+--- binwalk-2.0.1/Makefile.in
++++ binwalk-2.0.1/Makefile.in
+@@ -33,21 +33,20 @@
+ $(PYTHON) ./setup.py install $(PREFIX)
+
+ build:
+- if [ "$(BUILD_C_LIBS)" -eq "1" ]; then make -C $(SRC_C_DIR); fi
+- if [ "$(BUILD_BUNDLES)" -eq "1" ]; then make -C $(SRC_BUNDLES_DIR); fi
+- $(PYTHON) ./setup.py build
++ if [ "$(BUILD_C_LIBS)" -eq "1" ]; then $(MAKE) -C $(SRC_C_DIR); fi
++ if [ "$(BUILD_BUNDLES)" -eq "1" ]; then $(MAKE) -C $(SRC_BUNDLES_DIR); fi
+
+ deps:
+ ./deps.sh
+
+ clean:
+- if [ "$(BUILD_C_LIBS)" -eq "1" ]; then make -C $(SRC_C_DIR) clean; fi
+- if [ "$(BUILD_BUNDLES)" -eq "1" ]; then make -C $(SRC_BUNDLES_DIR) clean; fi
++ if [ "$(BUILD_C_LIBS)" -eq "1" ]; then $(MAKE) -C $(SRC_C_DIR) clean; fi
++ if [ "$(BUILD_BUNDLES)" -eq "1" ]; then $(MAKE) -C $(SRC_BUNDLES_DIR) clean; fi
+ $(PYTHON) ./setup.py clean
+
+ distclean: clean
+- if [ "$(BUILD_C_LIBS)" -eq "1" ]; then make -C $(SRC_C_DIR) distclean; fi
+- if [ "$(BUILD_BUNDLES)" -eq "1" ]; then make -C $(SRC_BUNDLES_DIR) distclean; fi
++ if [ "$(BUILD_C_LIBS)" -eq "1" ]; then $(MAKE) -C $(SRC_C_DIR) distclean; fi
++ if [ "$(BUILD_BUNDLES)" -eq "1" ]; then $(MAKE) -C $(SRC_BUNDLES_DIR) distclean; fi
+ rm -rf Makefile config.* *.cache
+
+ uninstall:
+--- binwalk-2.0.1/src/C/Makefile
++++ binwalk-2.0.1/src/C/Makefile
+@@ -3,9 +3,9 @@
+ .PHONY: all clean_libs clean distclean
+
+ all:
+- make -C miniz
++ $(MAKE) -C miniz
+ cp miniz/*.$(SOEXT) $(LIB_DIR)
+- make -C compress
++ $(MAKE) -C compress
+ cp compress/*.$(SOEXT) $(LIB_DIR)
+
+ clean_libs:
+@@ -13,10 +13,10 @@
+ rm -f $(LIB_DIR)/libcompress42.$(SOEXT)
+
+ clean: clean_libs
+- make -C miniz clean
+- make -C compress clean
++ $(MAKE) -C miniz clean
++ $(MAKE) -C compress clean
+
+ distclean: clean_libs
+- make -C miniz distclean
+- make -C compress distclean
++ $(MAKE) -C miniz distclean
++ $(MAKE) -C compress distclean
+