summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-08-01 18:01:28 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-08-15 21:53:29 +0200
commite95517277520928e758c5e7c2c772f2a95a1da08 (patch)
treeb1ec39f68fd84df0e031d6ec5a4f7a11ada637c1 /app-misc/cdspeed
parentapp-misc/cdcat: EAPI7, improve ebuild (diff)
downloadgentoo-e95517277520928e758c5e7c2c772f2a95a1da08.tar.gz
gentoo-e95517277520928e758c5e7c2c772f2a95a1da08.tar.bz2
gentoo-e95517277520928e758c5e7c2c772f2a95a1da08.zip
app-misc/cdspeed: EAPI7, improve ebuild
Closes: https://github.com/gentoo/gentoo/pull/9411
Diffstat (limited to 'app-misc/cdspeed')
-rw-r--r--app-misc/cdspeed/cdspeed-0.4-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-misc/cdspeed/cdspeed-0.4-r2.ebuild b/app-misc/cdspeed/cdspeed-0.4-r2.ebuild
new file mode 100644
index 000000000000..6c933ac2caff
--- /dev/null
+++ b/app-misc/cdspeed/cdspeed-0.4-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Change the speed of your CD drive"
+HOMEPAGE="http://linuxfocus.org/~guido/"
+SRC_URI="http://linuxfocus.org/~guido/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~x86"
+
+src_prepare() {
+ default
+ sed -i Makefile \
+ -e 's| -o | $(LDFLAGS)&|g' \
+ || die "sed Makefile failed"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} -Wall -Wno-unused" CC=$(tc-getCC)
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ dodoc README
+}