summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/devtodo/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/devtodo/files')
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch32
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.20-gcc43.patch10
-rw-r--r--app-misc/devtodo/files/devtodo-0.1.20-gentoo.diff85
-rw-r--r--app-misc/devtodo/files/devtodo.bash-completion44
4 files changed, 171 insertions, 0 deletions
diff --git a/app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch b/app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch
new file mode 100644
index 000000000000..8567ab4b0562
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.20-bashcom_spaces.patch
@@ -0,0 +1,32 @@
+ contrib/devtodo.bash-completion | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/contrib/devtodo.bash-completion b/contrib/devtodo.bash-completion
+index 07139b0..c058dad 100644
+--- a/contrib/devtodo.bash-completion
++++ b/contrib/devtodo.bash-completion
+@@ -15,20 +15,20 @@ _devtodo() {
+ --purge"
+
+ if [[ ${cur} == -* || ${COMP_CWORD} -eq 1 ]] ; then
+- COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
++ COMPREPLY=( $(compgen -W "${opts}" -- "${cur}") )
+ return 0
+ fi
+
+ case "${prev}" in
+ -p|--priority)
+ COMPREPLY=( $(compgen -W "default veryhigh high medium low verylow" \
+- -- ${cur}) )
++ -- "${cur}") )
+ ;;
+ --database-loaders)
+- COMPREPLY=( $(compgen -W "xml binary" -- ${cur}) )
++ COMPREPLY=( $(compgen -W "xml binary" -- "${cur}") )
+ ;;
+ -l|--link|--*database)
+- COMPREPLY=( $(compgen -f -- ${cur}) )
++ _filedir
+ ;;
+ *)
+ COMPREPLY=()
diff --git a/app-misc/devtodo/files/devtodo-0.1.20-gcc43.patch b/app-misc/devtodo/files/devtodo-0.1.20-gcc43.patch
new file mode 100644
index 000000000000..f9f920545805
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.20-gcc43.patch
@@ -0,0 +1,10 @@
+--- devtodo-0.1.20.orig/src/todoterm.cc
++++ devtodo-0.1.20/src/todoterm.cc
+@@ -2,6 +2,7 @@
+ #include "todoterm.h"
+
+ #ifdef USETERMCAP
++#include <cstdlib>
+ #include <iostream>
+ #include <string>
+ #include <stdexcept>
diff --git a/app-misc/devtodo/files/devtodo-0.1.20-gentoo.diff b/app-misc/devtodo/files/devtodo-0.1.20-gentoo.diff
new file mode 100644
index 000000000000..05c36a31880c
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo-0.1.20-gentoo.diff
@@ -0,0 +1,85 @@
+--- devtodo-0.1.20.orig/doc/devtodo.1.in 2004-12-17 10:21:09.135350872 -0500
++++ devtodo-0.1.20/doc/devtodo.1.in 2004-12-17 10:21:34.050210242 -0500
+@@ -20,9 +20,6 @@
+ .TP
+ \fBtdd \fI<indices>\fP\fP
+ Mark the specified items as being done.
+-.TP
+-\fBtdl [\-g \fI<index>\fP] \fI<database>\fP\fP
+-Link the specified devtodo database into the current one, optionally grafting it as a child of the specified index.
+ .SH "DESCRIPTION"
+ .LP
+ \fBtodo\fP is a program aimed specifically at programmers (but usable by anybody at the terminal) to aid in day\-to\-day development.
+@@ -372,6 +369,10 @@
+ .TP
+ \fB~/.todorc\fR
+ User-specific options are specified in this file. Please refer to the section \fBTODORC\fR for more information.
++.SH "BUGS"
++.LP
++Because of a conflict with app-misc/tdl, the tdl symbolic link and the tdl manual page have been removed.
++See \fIhttp://bugs.gentoo.org/show_bug.cgi?id=55371\fR for more information.
+ .SH "AUTHORS"
+ .LP
+ Alec Thomas \fI<alec@swapoff.org>\fR
+--- devtodo-0.1.20.orig/doc/Makefile.am 2004-12-17 10:21:09.135350872 -0500
++++ devtodo-0.1.20/doc/Makefile.am 2004-12-17 10:21:34.050210242 -0500
+@@ -1,5 +1,5 @@
+ man_MANS=devtodo.1
+-manlinks=tda tdr tdd tde tdl todo
++manlinks=tda tdr tdd tde todo
+
+ install-data-local:
+ mkdir -p $(DESTDIR)$(mandir)/man1
+--- devtodo-0.1.20.orig/src/TodoDB.cc 2004-12-17 10:21:09.136350706 -0500
++++ devtodo-0.1.20/src/TodoDB.cc 2004-12-17 10:21:34.054209577 -0500
+@@ -949,7 +948,11 @@
+ if (out.bad())
+ throw exception("couldn't open TODO for generation");
+
+- if (titleText != "") wraptext(out, titleText, 0, options.columns);
++ if (titleText != "") {
++ wraptext(out, titleText, 0, options.columns);
++ out << endl << endl;
++ }
++
+ if (options.verbose > 1)
+ cout << "todo: generating using format '" << options.format["verbose-generated"] << "'" << endl;
+ filterView();
+--- devtodo-0.1.20/contrib/devtodo.bash-completion {cset 9b4d9f02-fdb7-4641-b07f-7359b794d6b0}
++++ devtodo-0.1.20/contrib/devtodo.bash-completion {local clone}
+@@ -35,6 +35,6 @@ _devtodo() {
+ ;;
+ esac
+ }
+-complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd tdl
++complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd
+
+ # vim: set ft=sh tw=80 sw=4 et :
+--- devtodo-0.1.20/src/support.cc {cset 5f5bd9cb-18fb-4046-bff5-4f3dbd781e47}
++++ devtodo-0.1.20/src/support.cc {local clone}
+@@ -289,11 +289,10 @@ enum { Help = -100, Remove, Version, Tit
+ << "Where <arguments> can be any of the following:" << endl;
+ args.displayHelp(cout, options.columns);
+ cout << endl
+- << "In addition, there are five convenience symlinks. These are 'tda', 'tdr'," << endl
+- << "'tdd', 'tde', and 'tdl'. For 'tde', 'tdd' and 'tdr' supply an index to edit," << endl
++ << "In addition, there are four convenience symlinks. These are 'tda', 'tdr'," << endl
++ << "'tdd', and 'tde'. For 'tde', 'tdd' and 'tdr' supply an index to edit," << endl
+ << "mark done and remove respectively. For 'tda' supply the text of the todo item" << endl
+- << "item and optionally the priority. For 'tdl' supply the path to another todo" << endl
+- << "file to link in to the current todo file." << endl
++ << "item and optionally the priority." << endl
+ << "eg. tde 1" << endl;
+ exit(0);
+ break;
+--- devtodo-0.1.20/src/Makefile.am 2007-09-17 12:12:55.000000000 +0200
++++ devtodo-0.1.20/src/Makefile.am 2007-09-17 12:13:43.000000000 +0200
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS=devtodo
+ devtodo_SOURCES=Todo.cc Todo.h TodoDB.cc TodoDB.h support.cc support.h \
+ main.cc todoterm.cc todoterm.h Loaders.cc Loaders.h todorl.h
+-binlinks=tda tdr tdd tdl tde todo
++binlinks=tda tdr tdd tde todo
+
+ devtodo_LDADD=../util/libutil.la
+ INCLUDES=-I../util
diff --git a/app-misc/devtodo/files/devtodo.bash-completion b/app-misc/devtodo/files/devtodo.bash-completion
new file mode 100644
index 000000000000..ae2dacddc5aa
--- /dev/null
+++ b/app-misc/devtodo/files/devtodo.bash-completion
@@ -0,0 +1,44 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# bash command-line completion for devtodo
+# Author: Aaron Walker <ka0ttic@gentoo.org>
+
+_devtodo() {
+ local cur prev opts
+ COMPREPLY=()
+ cur="${COMP_WORDS[COMP_CWORD]}"
+ prev="${COMP_WORDS[COMP_CWORD-1]}"
+ opts="-v --verbose -a --add -g --graft -l --link -R --reparent
+ -p --priority -e --edit --remove -d --done -D --not-done
+ --global-database -G --global --database -T --TODO -A --all
+ -f --filter --colour --force-colour --mono --help --version
+ --title --date-format --format --use-format --sort --paranoid
+ --database-loaders --backup -s --summary -c --comment --timeout
+ --purge"
+
+ if [[ "${cur}" == -* || ${COMP_CWORD} -eq 1 ]] ; then
+ COMPREPLY=( $(compgen -W "${opts}" -- ${cur}) )
+ return 0
+ fi
+
+ case "${prev}" in
+ -p|--priority)
+ COMPREPLY=( $(compgen -W "default veryhigh high medium low verylow" \
+ -- ${cur}) )
+ ;;
+ --database-loaders)
+ COMPREPLY=( $(compgen -W "xml binary" -- ${cur}) )
+ ;;
+ -l|--link|--*database)
+ COMPREPLY=( $(compgen -f -- ${cur}) )
+ ;;
+ *)
+ COMPREPLY=()
+ ;;
+ esac
+}
+complete -o filenames -F _devtodo devtodo todo tda tde tdr tdd
+
+# vim: set ft=sh tw=80 sw=4 et :