summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 04:29:28 +0000
committerSam James <sam@gentoo.org>2021-04-19 04:30:59 +0000
commit6ec9dad231bd86a6febc4c318724c7b1920dcf63 (patch)
tree58b0d838aba4ee90c518972713aa513de8439303 /app-misc/digitemp
parentapp-misc/realpath: port to EAPI 7 (diff)
downloadgentoo-6ec9dad231bd86a6febc4c318724c7b1920dcf63.tar.gz
gentoo-6ec9dad231bd86a6febc4c318724c7b1920dcf63.tar.bz2
gentoo-6ec9dad231bd86a6febc4c318724c7b1920dcf63.zip
app-misc/digitemp: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/digitemp')
-rw-r--r--app-misc/digitemp/digitemp-3.7.1.ebuild28
1 files changed, 15 insertions, 13 deletions
diff --git a/app-misc/digitemp/digitemp-3.7.1.ebuild b/app-misc/digitemp/digitemp-3.7.1.ebuild
index 01e1ebe0ca3a..65431c4aae4f 100644
--- a/app-misc/digitemp/digitemp-3.7.1.ebuild
+++ b/app-misc/digitemp/digitemp-3.7.1.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
inherit toolchain-funcs
@@ -9,10 +9,10 @@ DESCRIPTION="Temperature logging and reporting using Maxim's iButtons and 1-Wire
HOMEPAGE="https://www.digitemp.com/ https://www.ibutton.com/"
SRC_URI="https://github.com/bcl/digitemp/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-IUSE="ds9097 ds9097u ds2490"
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 x86"
+IUSE="ds9097 ds9097u ds2490"
DEPEND="ds2490? ( virtual/libusb:0 )"
@@ -21,6 +21,7 @@ targets() {
if ! ( use ds9097 || use ds9097u || use ds2490 ); then
echo ds9097u
fi
+
for target in ds9097 ds9097u ds2490; do
if use ${target}; then
echo ${target}
@@ -29,8 +30,13 @@ targets() {
}
src_prepare() {
- sed -i -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
- -e "/^LIBS/s:=:= ${LDFLAGS}:" Makefile
+ default
+
+ sed -i \
+ -e "/^CFLAGS/s:-O2:${CFLAGS}:" \
+ -e "/^LIBS/s:=:= ${LDFLAGS}:" \
+ Makefile || die
+
# default is to compile to the ds9097u.
if ! ( use ds9097 || use ds9097u || use ds2490 ); then
ewarn "If you don't choose a component to install, we default to ds9097u"
@@ -40,9 +46,9 @@ src_prepare() {
src_compile() {
local targets=$(targets)
- for target in $targets; do
+ for target in ${targets}; do
emake clean
- emake CC="$(tc-getCC)" LOCK="no" ${target}
+ emake CC="$(tc-getCC)" LOCK="no" ${target}
done
}
@@ -53,23 +59,19 @@ src_install() {
done
if [[ $(targets|wc -l) -ge 1 ]]; then
- echo
ewarn "/usr/bin/digitemp has been symlinked to /usr/bin/digitemp_${target}"
ewarn "If you want to access the others, they are available at /usr/bin/digitemp_*"
- echo
fi
dodoc README FAQ TODO
for example in perl python rrdb; do
- insinto "/usr/share/doc/${PF}/${example}_examples"
- doins -r ${example}/*
+ docinto ${example}_examples
+ dodoc -r ${example}/*
done
}
pkg_postinst() {
- echo
elog "Examples of using digitemp with python, perl, and rrdtool are"
elog "located in /usr/share/doc/${PF}/"
- echo
}