summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/egads
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/egads')
-rw-r--r--app-misc/egads/Manifest1
-rw-r--r--app-misc/egads/egads-0.9.5.ebuild50
-rw-r--r--app-misc/egads/metadata.xml8
3 files changed, 59 insertions, 0 deletions
diff --git a/app-misc/egads/Manifest b/app-misc/egads/Manifest
new file mode 100644
index 000000000000..3d581af09b36
--- /dev/null
+++ b/app-misc/egads/Manifest
@@ -0,0 +1 @@
+DIST egads-0.9.5.tar.gz 302708 SHA256 606d68e284540d357115d7c2d2952d22a2b293fe77f00599396aeeb5b47e36a1 SHA512 b3138d31165f25c4b4b83b72eeee5fd0ea80e2d89a1a67f1d6d40c82afd849ef76ebdb5e71165eb80c00c971dd0bb4e9660fcb70ffedb7e14a003be90ce91e7b WHIRLPOOL 90f2795416878f3af3205d251e2a9628c6fa5a0ba37ef467b5b51f10de2a4ea75a459e999bf2972c1c5c7a13f8340468e044641194ae67170cbe1ccbd3b59adb
diff --git a/app-misc/egads/egads-0.9.5.ebuild b/app-misc/egads/egads-0.9.5.ebuild
new file mode 100644
index 000000000000..965780695d14
--- /dev/null
+++ b/app-misc/egads/egads-0.9.5.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit multilib toolchain-funcs
+
+DESCRIPTION="Entropy Gathering And Distribution System"
+HOMEPAGE="http://www.securesoftware.com/download_${PN}.htm"
+SRC_URI="http://www.securesoftware.com/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~ppc x86 ~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+egadsdatadir=/var/run/egads
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e '/^BINDIR/d' \
+ -e '/^LIBDIR/d' \
+ -e '/^INCLUDEDIR/d' \
+ "${S}"/Makefile.in || die "Failed to fix Makefile.in"
+ tc-export CC AR RANLIB
+}
+
+src_compile() {
+ econf \
+ --with-egads-datadir="${egadsdatadir}" \
+ --with-bindir=/usr/sbin \
+ || die
+ emake LIBDIR="/usr/$(get_libdir)" || die
+}
+
+src_install() {
+ keepdir ${egadsdatadir}
+ fperms +t ${egadsdatadir}
+ # NOT parallel safe, and no DESTDIR support
+ emake -j1 install \
+ BINDIR="${D}"/usr/sbin \
+ LIBDIR="${D}"/usr/$(get_libdir) \
+ INCLUDEDIR="${D}"/usr/include \
+ || die
+ dodoc README* doc/*.txt
+ dohtml doc/*.html
+}
diff --git a/app-misc/egads/metadata.xml b/app-misc/egads/metadata.xml
new file mode 100644
index 000000000000..a732fd8b2f03
--- /dev/null
+++ b/app-misc/egads/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>