summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2020-11-14 21:17:44 +0100
committerDavid Seifert <soap@gentoo.org>2020-11-14 21:17:44 +0100
commite3f26bbd991c9eacc648096e4c85e8343ef4d82b (patch)
treed7035b42d091ed2822a159479762fb9360710f83 /app-misc/egads
parentapp-i18n/scim-m17n: disable static libs (diff)
downloadgentoo-e3f26bbd991c9eacc648096e4c85e8343ef4d82b.tar.gz
gentoo-e3f26bbd991c9eacc648096e4c85e8343ef4d82b.tar.bz2
gentoo-e3f26bbd991c9eacc648096e4c85e8343ef4d82b.zip
app-misc/egads: disable static libs
Closes: https://bugs.gentoo.org/726638 Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/egads')
-rw-r--r--app-misc/egads/egads-0.9.5-r1.ebuild7
1 files changed, 5 insertions, 2 deletions
diff --git a/app-misc/egads/egads-0.9.5-r1.ebuild b/app-misc/egads/egads-0.9.5-r1.ebuild
index 415f97ec2038..e6a0e21f3755 100644
--- a/app-misc/egads/egads-0.9.5-r1.ebuild
+++ b/app-misc/egads/egads-0.9.5-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -28,7 +28,8 @@ src_prepare() {
src_configure() {
econf \
--with-egads-datadir="${EGADS_DATADIR}" \
- --with-bindir=/usr/sbin
+ --with-bindir="${EPREFIX}"/usr/sbin \
+ --disable-static
}
src_compile() {
@@ -45,4 +46,6 @@ src_install() {
INCLUDEDIR="${D}"/usr/include
dodoc README* doc/*.txt doc/*.html
+
+ find "${ED}" -name '*.la' -delete || die
}