summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Mozes <hydrapolic@gmail.com>2018-05-24 14:09:16 +0200
committerAaron Bauman <bman@gentoo.org>2018-05-25 09:14:01 -0400
commit5aba6790b2be028415d93da4bf9f47a31ba0a96b (patch)
tree18f77fc5bec3aacb5f71d6970137a291a001c91a /app-misc/elasticsearch
parentapp-misc/elasticsearch: allow to override LOG_DIR (diff)
downloadgentoo-5aba6790b2be028415d93da4bf9f47a31ba0a96b.tar.gz
gentoo-5aba6790b2be028415d93da4bf9f47a31ba0a96b.tar.bz2
gentoo-5aba6790b2be028415d93da4bf9f47a31ba0a96b.zip
app-misc/elasticsearch: drop unsupported version 1.7
https://www.elastic.co/support/eol Package-Manager: Portage-2.3.38, Repoman-2.3.9
Diffstat (limited to 'app-misc/elasticsearch')
-rw-r--r--app-misc/elasticsearch/Manifest1
-rw-r--r--app-misc/elasticsearch/elasticsearch-1.7.6.ebuild71
-rw-r--r--app-misc/elasticsearch/files/elasticsearch.conf60
-rw-r--r--app-misc/elasticsearch/files/elasticsearch.init95
-rw-r--r--app-misc/elasticsearch/files/elasticsearch.init.164
5 files changed, 0 insertions, 291 deletions
diff --git a/app-misc/elasticsearch/Manifest b/app-misc/elasticsearch/Manifest
index 681b13ab5b8a..28c891fc7a1e 100644
--- a/app-misc/elasticsearch/Manifest
+++ b/app-misc/elasticsearch/Manifest
@@ -1,3 +1,2 @@
-DIST elasticsearch-1.7.6.tar.gz 28488767 BLAKE2B 0dc4fb10355e2139ee3a7e7e65366e8aa533b9714bf0f00d2bd8f4ef0669ba9f8f10dc5255c8c7a62abc0362e08ab5fda3c8b6b6f2bacfe5cce7255973293162 SHA512 2746f09b66919912e785c8d25c50ae74dbb38a41d99d9c926550786f9c2d7953d1ae1a54a32dae59a7269e5fbfa74dfbc91c3d412e415efd01c391ef7d329ba7
DIST elasticsearch-5.6.9.tar.gz 33794793 BLAKE2B a056443b1f71b3af773b5195147927017456e1c9a6517c549cfe7e4ec70f0ff4ec9363c9ef6376b7b942e82f811cd5927d44eb9f9eb8022a56e54a85b4ba7c46 SHA512 4e61a4c5f79d0439a414f1e9361f855cdb2f79322cf592bad43132605922fb8ded6368b01e05ef6bcbee49911943c2a3b6be5fd6d0900abddfe03c736cca96d6
DIST elasticsearch-6.2.4.tar.gz 29056810 BLAKE2B 121be27ac1db4fa6bbe285161b3f2b2dd889859b50f46b57b68ed43514568c4aa9629b5ca32edcc2328a6e7245256d64901c8acc8b2dd91337f8ca97b87c46e1 SHA512 9e6c0de8ed0d9e27fdd18ef7bada376af5a8680bb7a4f4d805926da456b349cee731ba90328b5eda5f0e62fa3f00f34646bf1c2b6c662d055f4be338d0690941
diff --git a/app-misc/elasticsearch/elasticsearch-1.7.6.ebuild b/app-misc/elasticsearch/elasticsearch-1.7.6.ebuild
deleted file mode 100644
index eca489c9bd2d..000000000000
--- a/app-misc/elasticsearch/elasticsearch-1.7.6.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils systemd user
-
-MY_PN="${PN%-bin}"
-DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
-HOMEPAGE="https://www.elastic.co/products/elasticsearch"
-SRC_URI="https://download.elastic.co/${MY_PN}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-
-RESTRICT="strip"
-QA_PREBUILT="usr/share/elasticsearch/lib/sigar/libsigar-*.so"
-
-RDEPEND="|| ( virtual/jre:1.7 virtual/jre:1.8 )"
-
-pkg_setup() {
- enewgroup ${MY_PN}
- enewuser ${MY_PN} -1 /bin/bash /var/lib/${MY_PN} ${MY_PN}
-}
-
-src_prepare() {
- rm -rf lib/sigar/*{solaris,winnt,freebsd,macosx}*
- rm -rf bin/*.{bat,exe}
- rm lib/sigar/libsigar-ia64-linux.so
- rm LICENSE.txt
-
- use amd64 && {
- rm lib/sigar/libsigar-x86-linux.so
- }
-
- use x86 && {
- rm lib/sigar/libsigar-amd64-linux.so
- }
- default
-}
-
-src_install() {
- dodir /etc/${MY_PN}
-
- insinto /usr/share/doc/${P}/examples
- doins config/*
- rm -rf config
-
- insinto /usr/share/${MY_PN}
- doins -r ./*
- chmod +x "${D}"/usr/share/${MY_PN}/bin/*
-
- keepdir /var/{lib,log}/${MY_PN}
-
- newinitd "${FILESDIR}/elasticsearch.init.1" "${MY_PN}"
- newconfd "${FILESDIR}/${MY_PN}.conf.3" "${MY_PN}"
- systemd_newunit "${FILESDIR}"/${PN}.service.2 "${PN}.service"
-}
-
-pkg_postinst() {
- elog
- elog "You may create multiple instances of ${MY_PN} by"
- elog "symlinking the init script:"
- elog "ln -sf /etc/init.d/${MY_PN} /etc/init.d/${MY_PN}.instance"
- elog
- elog "Each of the example files in /usr/share/doc/${P}/examples"
- elog "should be extracted to the proper configuration directory:"
- elog "/etc/${MY_PN} (for standard init)"
- elog "/etc/${MY_PN}/instance (for symlinked init)"
- elog
-}
diff --git a/app-misc/elasticsearch/files/elasticsearch.conf b/app-misc/elasticsearch/files/elasticsearch.conf
deleted file mode 100644
index 444ec53ae335..000000000000
--- a/app-misc/elasticsearch/files/elasticsearch.conf
+++ /dev/null
@@ -1,60 +0,0 @@
-################################
-# Elasticsearch
-################################
-
-# Elasticsearch home directory
-#ES_HOME=/usr/share/elasticsearch
-
-# Elasticsearch Java path
-#JAVA_HOME=
-
-# Elasticsearch configuration directory
-#CONF_DIR=/etc/elasticsearch
-
-# Elasticsearch data directory
-#DATA_DIR=/var/lib/elasticsearch
-
-# Elasticsearch logs directory
-#LOG_DIR=/var/log/elasticsearch
-
-# Elasticsearch PID directory
-#PID_DIR=/run/elasticsearch
-
-# Additional Java OPTS
-#ES_JAVA_OPTS=
-
-################################
-# Elasticsearch service
-################################
-
-# When executing the init script, this user will be used to run the elasticsearch service.
-# The default value is 'elasticsearch' and is declared in the init.d file.
-# Note that this setting is only used by the init script. If changed, make sure that
-# the configured user can read and write into the data, work, plugins and log directories.
-# For systemd service, the user is usually configured in file /usr/lib/systemd/system/elasticsearch.service
-#ES_USER=elasticsearch
-#ES_GROUP=elasticsearch
-
-# The number of seconds to wait before checking if Elasticsearch started successfully as a daemon process
-#ES_STARTUP_SLEEP_TIME=5
-
-################################
-# System properties
-################################
-
-# Specifies the maximum file descriptor number that can be opened by this process
-# When using Systemd, this setting is ignored and the LimitNOFILE defined in
-# /usr/lib/systemd/system/elasticsearch.service takes precedence
-#MAX_OPEN_FILES=65536
-
-# The maximum number of bytes of memory that may be locked into RAM
-# Set to "unlimited" if you use the 'bootstrap.memory_lock: true' option
-# in elasticsearch.yml.
-# When using Systemd, the LimitMEMLOCK property must be set
-# in /usr/lib/systemd/system/elasticsearch.service
-#MAX_LOCKED_MEMORY=unlimited
-
-# Maximum number of VMA (Virtual Memory Areas) a process can own
-# When using Systemd, this setting is ignored and the 'vm.max_map_count'
-# property is set at boot time in /usr/lib/sysctl.d/elasticsearch.conf
-#MAX_MAP_COUNT=262144
diff --git a/app-misc/elasticsearch/files/elasticsearch.init b/app-misc/elasticsearch/files/elasticsearch.init
deleted file mode 100644
index a9200d58ca0b..000000000000
--- a/app-misc/elasticsearch/files/elasticsearch.init
+++ /dev/null
@@ -1,95 +0,0 @@
-#!/sbin/openrc-run
-
-name="Elasticsearch"
-description="Elasticsearch Server"
-
-ES_INSTANCE=${SVCNAME#*.}
-PID_DIR=${PID_DIR:="/run/elasticsearch"}
-
-if [ -n "${ES_INSTANCE}" ] && [ ${SVCNAME} != "elasticsearch" ]; then
- PIDFILE="${PID_DIR}/elasticsearch.${ES_INSTANCE}.pid"
- ES_BASE_PATH="/var/lib/elasticsearch/${ES_INSTANCE}"
- CONF_DIR="/etc/elasticsearch/${ES_INSTANCE}"
- LOG_DIR="/var/log/elasticsearch/${ES_INSTANCE}"
-else
- PIDFILE="${PID_DIR}/elasticsearch.pid"
- ES_BASE_PATH="/var/lib/elasticsearch/_default"
- CONF_DIR="/etc/elasticsearch"
- LOG_DIR="/var/log/elasticsearch/_default"
-fi
-
-ES_HOME=${ES_HOME:="/usr/share/elasticsearch"}
-ES_USER=${ES_USER:="elasticsearch"}
-ES_GROUP=${ES_GROUP:="elasticsearch"}
-ES_STARTUP_SLEEP_TIME=${ES_STARTUP_TIME:=5}
-MAX_OPEN_FILES=${MAX_OPEN_FILES:=65536}
-MAX_MAP_COUNT=${MAX_MAP_COUNT:=262144}
-
-DATA_DIR=${DATA_DIR:="${ES_BASE_PATH}/data"}
-
-if [ -f "${CONF_DIR}/elasticsearch.in.sh" ]; then
- ES_INCLUDE="${CONF_DIR}/elasticsearch.in.sh"
-fi
-
-export ES_INCLUDE
-export JAVA_HOME
-export JAVA_OPTS
-export ES_JVM_OPTIONS
-export ES_JAVA_OPTS
-export ES_STARTUP_SLEEP_TIME
-
-server_command="/usr/share/elasticsearch/bin/elasticsearch"
-server_args="-d -p ${PIDFILE} -Edefault.path.logs=${LOG_DIR} -Edefault.path.data=${DATA_DIR} -Edefault.path.conf=${CONF_DIR}"
-
-depend() {
- use net
-}
-
-start() {
- local conf
- local conf_file
- for conf in elasticsearch.yml; do
- conf_file="${CONF_DIR}/${conf}"
- if [ ! -f "${conf_file}" ]; then
- eerror "${conf_file} must be copied into place"
- return 1
- fi
- done
-
- if [ -n "${MAX_MAP_COUNT}" -a -f /proc/sys/vm/max_map_count ]; then
- sysctl -q -w vm.max_map_count=${MAX_MAP_COUNT}
- fi
-
- ebegin "Starting ${SVCNAME}"
-
- if [ -n "${MAX_LOCKED_MEMORY}" ]; then
- ulimit -l "${MAX_LOCKED_MEMORY}"
- fi
-
- if [ -n "${MAX_OPEN_FILES}" ]; then
- ulimit -n "${MAX_OPEN_FILES}"
- fi
-
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "/var/lib/elasticsearch"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "/var/log/elasticsearch"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "${PID_DIR}"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "${ES_BASE_PATH}"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "${LOG_DIR}"
-
- start-stop-daemon --start \
- --background \
- --chdir "${ES_HOME}" \
- --user="${ES_USER}" \
- --pidfile="${PIDFILE}" \
- --exec ${server_command} -- ${server_args}
- eend $?
-}
-
-stop() {
- ebegin "Stopping ${SVCNAME}"
- start-stop-daemon --stop \
- --pidfile=${PIDFILE} \
- --user="${ES_USER}" \
- --retry=TERM/20
- eend $?
-}
diff --git a/app-misc/elasticsearch/files/elasticsearch.init.1 b/app-misc/elasticsearch/files/elasticsearch.init.1
deleted file mode 100644
index c44671c95d1b..000000000000
--- a/app-misc/elasticsearch/files/elasticsearch.init.1
+++ /dev/null
@@ -1,64 +0,0 @@
-#!/sbin/openrc-run
-
-name="Elasticsearch"
-description="Elasticsearch Server"
-
-ES_INSTANCE=${SVCNAME#*.}
-
-if [ -n "${ES_INSTANCE}" ] && [ ${SVCNAME} != "elasticsearch" ]; then
- ES_BASE_PATH="/var/lib/elasticsearch/${ES_INSTANCE}"
- CONF_DIR="/etc/elasticsearch/${ES_INSTANCE}"
- LOG_DIR="/var/log/elasticsearch/${ES_INSTANCE}"
-else
- ES_BASE_PATH="/var/lib/elasticsearch/_default"
- CONF_DIR="/etc/elasticsearch"
- LOG_DIR="/var/log/elasticsearch/_default"
-fi
-
-ES_DATA_PATH="${ES_BASE_PATH}/data"
-ES_WORK_PATH="${ES_BASE_PATH}/work"
-
-ES_HOME=${ES_HOME:="/usr/share/elasticsearch"}
-ES_USER=${ES_USER:="elasticsearch"}
-ES_GROUP=${ES_GROUP:="elasticsearch"}
-ES_STARTUP_SLEEP_TIME=${ES_STARTUP_TIME:=5}
-MAX_OPEN_FILES=${MAX_OPEN_FILES:=65536}
-MAX_MAP_COUNT=${MAX_MAP_COUNT:=262144}
-
-DATA_DIR=${DATA_DIR:="${ES_BASE_PATH}/data"}
-
-if [ -f "${CONF_DIR}/elasticsearch.in.sh" ]; then
- ES_INCLUDE="${CONF_DIR}/elasticsearch.in.sh"
-fi
-
-export ES_INCLUDE
-export JAVA_HOME
-export JAVA_OPTS
-export ES_JVM_OPTIONS
-export ES_JAVA_OPTS
-export ES_STARTUP_SLEEP_TIME
-export ES_PATH_CONF="${CONF_DIR}"
-
-pidfile="/run/elasticsearch/${RC_SVCNAME}.pid"
-
-command="/usr/share/elasticsearch/bin/elasticsearch"
-command_args="-d --pidfile=${pidfile} -Des.default.path.conf=\"${CONF_DIR}\" -Des.default.path.data=\"${ES_DATA_PATH}\" -Des.default.path.work=\"${ES_WORK_PATH}\" -Des.default.path.logs=\"${LOG_DIR}\""
-command_user="${ES_USER}:${ES_GROUP}"
-required_files="${CONF_DIR}/elasticsearch.yml"
-retry="TERM/30/KILL/30"
-
-depend() {
- use net
-}
-
-start_pre() {
- if [ -n "${MAX_MAP_COUNT}" -a -f /proc/sys/vm/max_map_count ]; then
- sysctl -q -w vm.max_map_count=${MAX_MAP_COUNT}
- fi
-
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "/var/lib/elasticsearch"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "/var/log/elasticsearch"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "/run/elasticsearch"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "${ES_BASE_PATH}"
- checkpath -d -o "${ES_USER}:${ES_GROUP}" -m750 "${LOG_DIR}"
-}