summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2017-01-07 07:12:48 +0000
committerGöktürk Yüksek <gokturk@gentoo.org>2017-01-15 12:37:27 -0500
commitbff6cc9c66bd9f07df396ae533dd9251f7270112 (patch)
tree6bb19c9a697d35391d5d8a5de1c66c2e30dd90fb /app-misc/elasticsearch
parentapp-misc/elasticsearch: drop old (diff)
downloadgentoo-bff6cc9c66bd9f07df396ae533dd9251f7270112.tar.gz
gentoo-bff6cc9c66bd9f07df396ae533dd9251f7270112.tar.bz2
gentoo-bff6cc9c66bd9f07df396ae533dd9251f7270112.zip
app-misc/elasticsearch: improve ebuild
Diffstat (limited to 'app-misc/elasticsearch')
-rw-r--r--app-misc/elasticsearch/elasticsearch-5.1.1.ebuild39
1 files changed, 18 insertions, 21 deletions
diff --git a/app-misc/elasticsearch/elasticsearch-5.1.1.ebuild b/app-misc/elasticsearch/elasticsearch-5.1.1.ebuild
index 5c53a4efd476..eeefd4d71833 100644
--- a/app-misc/elasticsearch/elasticsearch-5.1.1.ebuild
+++ b/app-misc/elasticsearch/elasticsearch-5.1.1.ebuild
@@ -6,10 +6,9 @@ EAPI=6
inherit eutils systemd user
-MY_PN="${PN%-bin}"
DESCRIPTION="Open Source, Distributed, RESTful, Search Engine"
HOMEPAGE="https://www.elastic.co/products/elasticsearch"
-SRC_URI="https://artifacts.elastic.co/downloads/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+SRC_URI="https://artifacts.elastic.co/downloads/${PN}/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
@@ -18,8 +17,6 @@ RESTRICT="strip"
RDEPEND="virtual/jre:1.8"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
pkg_preinst() {
if has_version '<app-misc/elasticsearch-2.3.2'; then
export UPDATE_NOTES=1
@@ -27,8 +24,8 @@ pkg_preinst() {
}
pkg_setup() {
- enewgroup ${MY_PN}
- enewuser ${MY_PN} -1 /bin/bash /usr/share/${MY_PN} ${MY_PN}
+ enewgroup ${PN}
+ enewuser ${PN} -1 /bin/bash /usr/share/${PN} ${PN}
}
src_prepare() {
@@ -39,43 +36,43 @@ src_prepare() {
}
src_install() {
- keepdir /etc/${MY_PN}
- keepdir /etc/${MY_PN}/scripts
+ keepdir /etc/${PN}
+ keepdir /etc/${PN}/scripts
- insinto /etc/${MY_PN}
+ insinto /etc/${PN}
doins config/*
rm -rf config || die
- insinto /usr/share/${MY_PN}
+ insinto /usr/share/${PN}
doins -r ./*
- exeinto /usr/share/${MY_PN}/bin
+ exeinto /usr/share/${PN}/bin
doexe "${FILESDIR}/elasticsearch-systemd-pre-exec"
- chmod +x "${D}"/usr/share/${MY_PN}/bin/*
+ chmod +x "${D}"/usr/share/${PN}/bin/*
- keepdir /var/{lib,log}/${MY_PN}
- keepdir /usr/share/${MY_PN}/plugins
+ keepdir /var/{lib,log}/${PN}
+ keepdir /usr/share/${PN}/plugins
- systemd_newtmpfilesd "${FILESDIR}/${MY_PN}.tmpfiles.d" "${MY_PN}.conf"
+ systemd_newtmpfilesd "${FILESDIR}/${PN}.tmpfiles.d" "${PN}.conf"
insinto /etc/sysctl.d
- newins "${FILESDIR}/${MY_PN}.sysctl.d" "${MY_PN}.conf"
+ newins "${FILESDIR}/${PN}.sysctl.d" "${PN}.conf"
- newinitd "${FILESDIR}/elasticsearch.init7" "${MY_PN}"
- newconfd "${FILESDIR}/${MY_PN}.conf3" "${MY_PN}"
+ newinitd "${FILESDIR}/${PN}.init7" "${PN}"
+ newconfd "${FILESDIR}/${PN}.conf3" "${PN}"
systemd_newunit "${FILESDIR}"/${PN}.service5 "${PN}.service"
}
pkg_postinst() {
elog
- elog "You may create multiple instances of ${MY_PN} by"
+ elog "You may create multiple instances of ${PN} by"
elog "symlinking the init script:"
- elog "ln -sf /etc/init.d/${MY_PN} /etc/init.d/${MY_PN}.instance"
+ elog "ln -sf /etc/init.d/${PN} /etc/init.d/${PN}.instance"
elog
elog "Please make sure you put elasticsearch.yml and logging.yml"
elog "into the configuration directory of the instance:"
- elog "/etc/${MY_PN}/instance"
+ elog "/etc/${PN}/instance"
elog
if ! [ -z ${UPDATE_NOTES} ]; then
elog "This update changes some configuration variables. Please review"