summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/emelfm2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/emelfm2')
-rw-r--r--app-misc/emelfm2/Manifest2
-rw-r--r--app-misc/emelfm2/emelfm2-0.8.1.ebuild70
-rw-r--r--app-misc/emelfm2/emelfm2-0.9.1-r1.ebuild88
-rw-r--r--app-misc/emelfm2/emelfm2-0.9.1.ebuild88
-rw-r--r--app-misc/emelfm2/metadata.xml7
5 files changed, 255 insertions, 0 deletions
diff --git a/app-misc/emelfm2/Manifest b/app-misc/emelfm2/Manifest
new file mode 100644
index 000000000000..6c30ef031efc
--- /dev/null
+++ b/app-misc/emelfm2/Manifest
@@ -0,0 +1,2 @@
+DIST emelfm2-0.8.1.tar.bz2 1098199 SHA256 d38355628360e6bcdb69ef4affff03dd9f7cc9bd25c999b18b648a23c6f8bba7 SHA512 0f371459b8e4ca96beb45a8ed04ea2b757356c938cbd6927244abadc01f4c89f39ca50b8a86c4ff97e5c2d068405c1969c1d028a2fba650ec9326c39bb39a65f WHIRLPOOL 1dbe7848c44a79afb40a1c663503ad57a257d1b55b4e24e1cc0c7efd3bbe0be94e3a5ba9228bc1ee1933ad967b42492ecba7e2849a33a00d188592b6b3f26a72
+DIST emelfm2-0.9.1.tar.bz2 1217126 SHA256 bfb94ff4e40c0a9c0d2a6aeb0efa22e177accbf6abd3096226d93daecd23642f SHA512 bd3a1ad2338c80d6824a2a84736470ecfa7e93f455cc8e3243944833807fe9b3544e2fea6bd6ccbddaf0188ad89ce616ed146271f6ffabec80f5dfb2f1ad6f57 WHIRLPOOL 4eaa1d95396a23c5f00ef66784f9f124f8c79e5dfe820f8bc556037109d799f5b1d30ef25a51183116ba955c931c0ec161d0e8aa3d92b79f33f0baaba7edf21d
diff --git a/app-misc/emelfm2/emelfm2-0.8.1.ebuild b/app-misc/emelfm2/emelfm2-0.8.1.ebuild
new file mode 100644
index 000000000000..08a39bb70d5e
--- /dev/null
+++ b/app-misc/emelfm2/emelfm2-0.8.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A file manager that implements the popular two-pane design"
+HOMEPAGE="http://emelfm2.net/"
+SRC_URI="http://emelfm2.net/rel/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 ~sparc x86"
+IUSE="acl gimp kernel_linux nls policykit spell udisks"
+
+COMMON_DEPEND=">=dev-libs/glib-2.26:2
+ >=x11-libs/gtk+-2.12:2
+ acl? ( sys-apps/acl )
+ gimp? ( media-gfx/gimp )
+ policykit? ( sys-auth/polkit )
+ spell? ( >=app-text/gtkspell-2.0.14:2 )"
+RDEPEND="${COMMON_DEPEND}
+ udisks? ( sys-fs/udisks:0 )"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+RESTRICT="test"
+
+pkg_setup() {
+ emel_use() {
+ use ${1} && echo "${2}=1" || echo "${2}=0"
+ }
+
+ #363813
+ myemelconf=(
+ GTK3=0
+ DOCS_VERSION=1
+ $(emel_use nls I18N)
+ WITH_TRANSPARENCY=1
+ $(emel_use kernel_linux WITH_KERNELFAM)
+ $(emel_use spell EDITOR_SPELLCHECK)
+ $(emel_use udisks WITH_DEVKIT)
+ $(emel_use gimp WITH_THUMBS)
+ $(emel_use acl WITH_ACL)
+ $(emel_use policykit WITH_POLKIT)
+ STRIP=0
+ )
+}
+
+src_prepare() {
+ sed -i \
+ -e 's:dbus-glib-1::' \
+ -e 's:@$(CC):$(CC):g' \
+ -e 's:@$(BIN_MSGFMT):$(BIN_MSGFMT):g' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake LIB_DIR="/usr/$(get_libdir)" PREFIX="/usr" \
+ ${myemelconf[@]}
+}
+
+src_install() {
+ emake LIB_DIR="${D}/usr/$(get_libdir)" PREFIX="${D}/usr" \
+ ${myemelconf[@]} install $( use nls && echo install_i18n )
+ newicon icons/${PN}_48.png ${PN}.png
+}
diff --git a/app-misc/emelfm2/emelfm2-0.9.1-r1.ebuild b/app-misc/emelfm2/emelfm2-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..220b0dcb250b
--- /dev/null
+++ b/app-misc/emelfm2/emelfm2-0.9.1-r1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A file manager that implements the popular two-pane design"
+HOMEPAGE="http://emelfm2.net/"
+SRC_URI="http://emelfm2.net/rel/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl ansi gimp gtk3 kernel_linux nls policykit spell udisks"
+
+EMELFM2_LINGUAS=( de fr ja pl ru zh_CN )
+IUSE+=" ${EMELFM2_LINGUAS[@]/#/linguas_}"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.26:2
+ !gtk3? ( >=x11-libs/gtk+-2.12:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ acl? ( sys-apps/acl )
+ gimp? ( media-gfx/gimp )
+ policykit? ( sys-auth/polkit )
+ spell? ( >=app-text/gtkspell-2.0.14:2 )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ udisks? ( sys-fs/udisks:2 )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e 's:@$(BIN_MSGFMT):$(BIN_MSGFMT):g' \
+ -e 's:@$(CC):$(CC):g' \
+ -e 's:dbus-glib-1::' \
+ Makefile || die
+
+ local lingua
+ for lingua in ${EMELFM2_LINGUAS[@]}; do
+ use linguas_${lingua} || mv po/${lingua}.po{,.unwanted}
+ done
+}
+
+src_configure() {
+ myemelconf=(
+ $(usex acl WITH_ACL=1 WITH_ACL=0)
+ $(usex ansi WITH_OUTPUTSTYLES=1 WITH_OUTPUTSTYLES=0)
+ $(usex gimp WITH_THUMBS=1 WITH_THUMBS=0)
+ $(usex gtk3 'GTK3=1 GTK2=0' 'GTK3=0 GTK2=1')
+ $(usex kernel_linux WITH_KERNELFAM=1 WITH_KERNELFAM=0)
+ $(usex nls I18N=1 I18N=0)
+ $(usex policykit WITH_POLKIT=1 WITH_POLKIT=0)
+ $(usex spell EDITOR_SPELLCHECK=1 EDITOR_SPELLCHECK=0)
+ $(usex udisks WITH_UDISKS=1 WITH_UDISKS=0)
+ DOCS_VERSION=1
+ STRIP=0
+ WITH_TRANSPARENCY=1
+ )
+}
+
+src_compile() {
+ tc-export CC
+ emake \
+ LIB_DIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" \
+ ${myemelconf[@]}
+}
+
+src_install() {
+ emake \
+ LIB_DIR="${D}/usr/$(get_libdir)" \
+ PREFIX="${D}/usr" \
+ ${myemelconf[@]} \
+ install \
+ $(usex nls install_i18n '')
+
+ newicon icons/${PN}_48.png ${PN}.png
+}
diff --git a/app-misc/emelfm2/emelfm2-0.9.1.ebuild b/app-misc/emelfm2/emelfm2-0.9.1.ebuild
new file mode 100644
index 000000000000..063788506897
--- /dev/null
+++ b/app-misc/emelfm2/emelfm2-0.9.1.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="A file manager that implements the popular two-pane design"
+HOMEPAGE="http://emelfm2.net/"
+SRC_URI="http://emelfm2.net/rel/${P}.tar.bz2"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="acl ansi gimp gtk3 kernel_linux nls policykit spell udisks"
+
+EMELFM2_LINGUAS=( de fr ja pl ru zh_CN )
+IUSE+=" ${EMELFM2_LINGUAS[@]/#/linguas_}"
+
+COMMON_DEPEND="
+ >=dev-libs/glib-2.26:2
+ !gtk3? ( >=x11-libs/gtk+-2.12:2 )
+ gtk3? ( x11-libs/gtk+:3 )
+ acl? ( sys-apps/acl )
+ gimp? ( media-gfx/gimp )
+ policykit? ( sys-auth/polkit )
+ spell? ( >=app-text/gtkspell-2.0.14:2 )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ udisks? ( sys-fs/udisks:0 )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+RESTRICT="test"
+
+src_prepare() {
+ sed -i \
+ -e 's:@$(BIN_MSGFMT):$(BIN_MSGFMT):g' \
+ -e 's:@$(CC):$(CC):g' \
+ -e 's:dbus-glib-1::' \
+ Makefile || die
+
+ local lingua
+ for lingua in ${EMELFM2_LINGUAS[@]}; do
+ use linguas_${lingua} || mv po/${lingua}.po{,.unwanted}
+ done
+}
+
+src_configure() {
+ myemelconf=(
+ $(usex acl WITH_ACL=1 WITH_ACL=0)
+ $(usex ansi WITH_OUTPUTSTYLES=1 WITH_OUTPUTSTYLES=0)
+ $(usex gimp WITH_THUMBS=1 WITH_THUMBS=0)
+ $(usex gtk3 'GTK3=1 GTK2=0' 'GTK3=0 GTK2=1')
+ $(usex kernel_linux WITH_KERNELFAM=1 WITH_KERNELFAM=0)
+ $(usex nls I18N=1 I18N=0)
+ $(usex policykit WITH_POLKIT=1 WITH_POLKIT=0)
+ $(usex spell EDITOR_SPELLCHECK=1 EDITOR_SPELLCHECK=0)
+ $(usex udisks WITH_DEVKIT=1 WITH_DEVKIT=0)
+ DOCS_VERSION=1
+ STRIP=0
+ WITH_TRANSPARENCY=1
+ )
+}
+
+src_compile() {
+ tc-export CC
+ emake \
+ LIB_DIR="/usr/$(get_libdir)" \
+ PREFIX="/usr" \
+ ${myemelconf[@]}
+}
+
+src_install() {
+ emake \
+ LIB_DIR="${D}/usr/$(get_libdir)" \
+ PREFIX="${D}/usr" \
+ ${myemelconf[@]} \
+ install \
+ $(usex nls install_i18n '')
+
+ newicon icons/${PN}_48.png ${PN}.png
+}
diff --git a/app-misc/emelfm2/metadata.xml b/app-misc/emelfm2/metadata.xml
new file mode 100644
index 000000000000..d08cba0fd23e
--- /dev/null
+++ b/app-misc/emelfm2/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+ <use><flag name='ansi'>Add support for ANSI escape sequences</flag></use>
+ <use><flag name='gtk3'>Use <pkg>x11-libs/gtk:3</pkg> instead of <pkg>x11-libs/gtk:2</pkg></flag></use>
+</pkgmetadata>