summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/fdupes/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/fdupes/files')
-rw-r--r--app-misc/fdupes/files/fdupes-1.50_pre2-compare-file.patch58
-rw-r--r--app-misc/fdupes/files/fdupes-1.50_pre2-lfs.patch21
-rw-r--r--app-misc/fdupes/files/fdupes-1.50_pre2-makefile.patch23
-rw-r--r--app-misc/fdupes/files/fdupes-1.50_pre2-typo.patch12
-rw-r--r--app-misc/fdupes/files/fdupes-1.51-makefile.patch23
5 files changed, 137 insertions, 0 deletions
diff --git a/app-misc/fdupes/files/fdupes-1.50_pre2-compare-file.patch b/app-misc/fdupes/files/fdupes-1.50_pre2-compare-file.patch
new file mode 100644
index 000000000000..fa9e2a34a893
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-1.50_pre2-compare-file.patch
@@ -0,0 +1,58 @@
+diff -urNp fdupes-1.50-PR2.orig/fdupes.c fdupes-1.50-PR2/fdupes.c
+--- fdupes-1.50-PR2.orig/fdupes.c 2009-01-31 20:11:49.577968848 +0530
++++ fdupes-1.50-PR2/fdupes.c 2009-01-31 22:01:11.872219443 +0530
+@@ -492,7 +492,10 @@ file_t **checkmatch(filetree_t **root, f
+ else {
+ if (checktree->file->crcpartial == NULL) {
+ crcsignature = getcrcpartialsignature(checktree->file->d_name);
+- if (crcsignature == NULL) return NULL;
++ if (crcsignature == NULL) {
++ errormsg ("cannot read file %s\n", checktree->file->d_name);
++ return NULL;
++ }
+
+ checktree->file->crcpartial = (char*) malloc(strlen(crcsignature)+1);
+ if (checktree->file->crcpartial == NULL) {
+@@ -504,7 +507,10 @@ file_t **checkmatch(filetree_t **root, f
+
+ if (file->crcpartial == NULL) {
+ crcsignature = getcrcpartialsignature(file->d_name);
+- if (crcsignature == NULL) return NULL;
++ if (crcsignature == NULL) {
++ errormsg ("cannot read file %s\n", file->d_name);
++ return NULL;
++ }
+
+ file->crcpartial = (char*) malloc(strlen(crcsignature)+1);
+ if (file->crcpartial == NULL) {
+@@ -577,8 +583,8 @@ file_t **checkmatch(filetree_t **root, f
+
+ int confirmmatch(FILE *file1, FILE *file2)
+ {
+- unsigned char c1 = 0;
+- unsigned char c2 = 0;
++ unsigned char c1[CHUNK_SIZE];
++ unsigned char c2[CHUNK_SIZE];
+ size_t r1;
+ size_t r2;
+
+@@ -586,14 +592,13 @@ int confirmmatch(FILE *file1, FILE *file
+ fseek(file2, 0, SEEK_SET);
+
+ do {
+- r1 = fread(&c1, sizeof(c1), 1, file1);
+- r2 = fread(&c2, sizeof(c2), 1, file2);
++ r1 = fread(c1, 1, sizeof(c1), file1);
++ r2 = fread(c2, 1, sizeof(c2), file2);
+
+- if (c1 != c2) return 0; /* file contents are different */
+- } while (r1 && r2);
++ if (r1 != r2) return 0; /* file lengths are different */
++ if (memcmp (c1, c2, r1)) return 0; /* file contents are different */
++ } while (r2);
+
+- if (r1 != r2) return 0; /* file lengths are different */
+-
+ return 1;
+ }
+
diff --git a/app-misc/fdupes/files/fdupes-1.50_pre2-lfs.patch b/app-misc/fdupes/files/fdupes-1.50_pre2-lfs.patch
new file mode 100644
index 000000000000..bd63f83291c1
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-1.50_pre2-lfs.patch
@@ -0,0 +1,21 @@
+diff -urNp fdupes-1.50-PR2.orig/fdupes.c fdupes-1.50-PR2/fdupes.c
+--- fdupes-1.50-PR2.orig/fdupes.c 2009-01-31 20:11:49.577968848 +0530
++++ fdupes-1.50-PR2/fdupes.c 2009-01-31 20:29:17.103220311 +0530
+@@ -643,7 +643,7 @@ void printmatches(file_t *files)
+ while (files != NULL) {
+ if (files->hasdupes) {
+ if (!ISFLAG(flags, F_OMITFIRST)) {
+- if (ISFLAG(flags, F_SHOWSIZE)) printf("%ld byte%seach:\n", files->size,
++ if (ISFLAG(flags, F_SHOWSIZE)) printf("%lld byte%seach:\n", files->size,
+ (files->size != 1) ? "s " : " ");
+ if (ISFLAG(flags, F_DSAMELINE)) escapefilename("\\ ", &files->d_name);
+ printf("%s%c", files->d_name, ISFLAG(flags, F_DSAMELINE)?' ':'\n');
+@@ -796,7 +796,7 @@ void deletefiles(file_t *files, int prom
+ do {
+ printf("Set %d of %d, preserve files [1 - %d, all]",
+ curgroup, groups, counter);
+- if (ISFLAG(flags, F_SHOWSIZE)) printf(" (%ld byte%seach)", files->size,
++ if (ISFLAG(flags, F_SHOWSIZE)) printf(" (%lld byte%seach)", files->size,
+ (files->size != 1) ? "s " : " ");
+ printf(": ");
+ fflush(stdout);
diff --git a/app-misc/fdupes/files/fdupes-1.50_pre2-makefile.patch b/app-misc/fdupes/files/fdupes-1.50_pre2-makefile.patch
new file mode 100644
index 000000000000..ed2e9871d869
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-1.50_pre2-makefile.patch
@@ -0,0 +1,23 @@
+--- fdupes-1.50-PR2/Makefile.orig 2010-11-19 19:05:18.152330536 -0800
++++ fdupes-1.50-PR2/Makefile 2010-11-19 19:06:00.998659992 -0800
+@@ -72,9 +72,9 @@
+ # Make Configuration
+ #
+ CC = gcc
+-COMPILER_OPTIONS = -Wall -O -g
++COMPILER_OPTIONS = -Wall
+
+-CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(EXPERIMENTAL_RBTREE) $(OMIT_GETOPT_LONG)
++CFLAGS += $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(EXPERIMENTAL_RBTREE) $(OMIT_GETOPT_LONG)
+
+ INSTALL_PROGRAM = $(INSTALL) -c -m 0755
+ INSTALL_DATA = $(INSTALL) -c -m 0644
+@@ -94,7 +94,7 @@
+ all: fdupes
+
+ fdupes: $(OBJECT_FILES)
+- $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o fdupes $(OBJECT_FILES)
+
+ installdirs:
+ test -d $(BIN_DIR) || -$(MKDIR) $(BIN_DIR)
diff --git a/app-misc/fdupes/files/fdupes-1.50_pre2-typo.patch b/app-misc/fdupes/files/fdupes-1.50_pre2-typo.patch
new file mode 100644
index 000000000000..1615a15f49b1
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-1.50_pre2-typo.patch
@@ -0,0 +1,12 @@
+diff -urNp fdupes-1.50-PR2.orig/fdupes.1 fdupes-1.50-PR2/fdupes.1
+--- fdupes-1.50-PR2.orig/fdupes.1 2009-01-31 20:11:49.581967819 +0530
++++ fdupes-1.50-PR2/fdupes.1 2009-01-31 20:32:46.383969471 +0530
+@@ -84,7 +84,7 @@ If fdupes returns with an error message
+ .B fdupes: error invoking md5sum
+ it means the program has been compiled to use an external
+ program to calculate MD5 signatures (otherwise, fdupes uses
+-interal routines for this purpose), and an error has occurred
++internal routines for this purpose), and an error has occurred
+ while attempting to execute it. If this is the case, the
+ specified program should be properly installed prior
+ to running fdupes.
diff --git a/app-misc/fdupes/files/fdupes-1.51-makefile.patch b/app-misc/fdupes/files/fdupes-1.51-makefile.patch
new file mode 100644
index 000000000000..138914239a90
--- /dev/null
+++ b/app-misc/fdupes/files/fdupes-1.51-makefile.patch
@@ -0,0 +1,23 @@
+--- fdupes-1.50-PR2/Makefile.orig 2010-11-19 19:05:18.152330536 -0800
++++ fdupes-1.50-PR2/Makefile 2010-11-19 19:06:00.998659992 -0800
+@@ -72,9 +72,9 @@
+ # Make Configuration
+ #
+ CC = gcc
+-COMPILER_OPTIONS = -Wall -O -g
++COMPILER_OPTIONS = -Wall
+
+-CFLAGS= $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
++CFLAGS += $(COMPILER_OPTIONS) -I. -DVERSION=\"$(VERSION)\" $(EXTERNAL_MD5) $(OMIT_GETOPT_LONG) $(FILEOFFSET_64BIT)
+
+ INSTALL_PROGRAM = $(INSTALL) -c -m 0755
+ INSTALL_DATA = $(INSTALL) -c -m 0644
+@@ -94,7 +94,7 @@
+ all: fdupes
+
+ fdupes: $(OBJECT_FILES)
+- $(CC) $(CFLAGS) -o fdupes $(OBJECT_FILES)
++ $(CC) $(CFLAGS) $(LDFLAGS) -o fdupes $(OBJECT_FILES)
+
+ installdirs:
+ test -d $(BIN_DIR) || $(MKDIR) $(BIN_DIR)