summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-02 22:46:44 +0100
committerSam James <sam@gentoo.org>2022-03-09 14:47:45 +0000
commitd8c28af972c4fa3cb6a6df5a69e6a21d0ae92c88 (patch)
treef7b345217da2b455f97c3ab946cff4d89b125fed /app-misc/fdutils
parentdev-cpp/libgnomecanvasmm: update EAPI 5 -> 8 (diff)
downloadgentoo-d8c28af972c4fa3cb6a6df5a69e6a21d0ae92c88.tar.gz
gentoo-d8c28af972c4fa3cb6a6df5a69e6a21d0ae92c88.tar.bz2
gentoo-d8c28af972c4fa3cb6a6df5a69e6a21d0ae92c88.zip
app-misc/fdutils: New version (5.6_p2)
* Bumps to EAPI=8 * Most patching from previous version is no longer necessary (except for one) * Keeps all the Debian patches minus one Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://bugs.gentoo.org/826430 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Closes: https://github.com/gentoo/gentoo/pull/24393 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/fdutils')
-rw-r--r--app-misc/fdutils/Manifest2
-rw-r--r--app-misc/fdutils/fdutils-5.6_p2.ebuild64
-rw-r--r--app-misc/fdutils/files/fdutils-5.6_p2-docs-build.patch28
-rw-r--r--app-misc/fdutils/files/fdutils-5.6_p2-parallel.patch26
4 files changed, 120 insertions, 0 deletions
diff --git a/app-misc/fdutils/Manifest b/app-misc/fdutils/Manifest
index 94c7a9272116..d680a65c5d63 100644
--- a/app-misc/fdutils/Manifest
+++ b/app-misc/fdutils/Manifest
@@ -2,3 +2,5 @@ DIST fdutils-5.5-20060227_20081027.diff.gz 6748 BLAKE2B a6d9bf332a777c6c09c85ea8
DIST fdutils_5.5-20060227-6.debian.tar.gz 54489 BLAKE2B 4d0fbd1c9c4f115a9df3f7092e062173f6a8956df8d465bb0186f712f51f6ef9e4fc67c4c642cdf7ae7e9daa775d6657c4306f5837307a51daa0abcc12639b0e SHA512 db6759bd2b98ae65bca39cf5b09fdb250371e02daa7665d8d21f93c3ab968cfe345cecb20faedaf2600104b22e2fb4df6868860dac3ead0ffb28d2141c8d7149
DIST fdutils_5.5-20060227-8.debian.tar.xz 48480 BLAKE2B 16de5a3b9f634c3eafbe9048d84c6ff29933e5b5ad878de79e6b03aac49ec44334e7e8e090ad0518bc83e8adb91dd19612850f0de7e28bc9d9c10663fd9a5252 SHA512 a55823c2a4defe1ebad5a92c96a85766520a744b75f49e9f99eb14ec2c0ec44f91a72437d070942a4603f7e337ed60c380f61635b4aba57dbb5ddc8d771d8b89
DIST fdutils_5.5-20060227.orig.tar.gz 222915 BLAKE2B d76a4b30ab60ea081e333817af11fe3815e8e19149c643afbcb931dc670fa3893cb96bb6be2136dea10fea06894a02e7fd1ecc4500ca6dd786054bbdaea19262 SHA512 a25d23827b9178a9a54d0012ad20248072e07aa5798bb3661fd0412d2441239b7bbf1778b5e34acb1a09a25a76e44c1801b706a242ce3b2337c06757e0ac02dd
+DIST fdutils_5.6-2.debian.tar.xz 49420 BLAKE2B 6f21a07fc9eeea3588b5b810cfc0e20e8c9e3ba905caa4274643aceeb452cf62d9a8449d25f25d73f87933ed9fc1654fede129874218f497ea4dcba82fbb58cc SHA512 b75d3b9185de51aae9ffc6e851b43b9722bb258b6d1c7517994a04bdf4607b53648291d0c755af2822d6503fe41150b08a56e59ccc4be604f23429cb10eb60b8
+DIST fdutils_5.6.orig.tar.gz 231851 BLAKE2B 461a145f5cc698e110e699cebadd887283cc53eaa06fd06b35f34658696fa27fdd443012e26bfc29d26db5e8db15d664c91230f7c7c2d89439bcbc8ea649536f SHA512 5b8c4b4f08657f7dd8bcbddddb5943df30386731c59be8fccd7da40504569c2fab48697d91937f0f50c19a51f84f2a191803139a93fafa10f8a3003cbd75faab
diff --git a/app-misc/fdutils/fdutils-5.6_p2.ebuild b/app-misc/fdutils/fdutils-5.6_p2.ebuild
new file mode 100644
index 000000000000..4f40a982f956
--- /dev/null
+++ b/app-misc/fdutils/fdutils-5.6_p2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_P=${PN}_5.6
+
+DESCRIPTION="Utilities for configuring and debugging the Linux floppy driver"
+HOMEPAGE="https://fdutils.linux.lu"
+SRC_URI="
+ mirror://debian/pool/main/f/${PN}/${MY_P}.orig.tar.gz
+ mirror://debian/pool/main/f/${PN}/${MY_P}-2.debian.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc"
+
+RDEPEND=">=sys-fs/mtools-4"
+DEPEND="${RDEPEND}
+ virtual/os-headers
+"
+BDEPEND="
+ sys-apps/texinfo
+ doc? ( virtual/texi2dvi )
+"
+
+S="${WORKDIR}/${PN}-5.6"
+
+src_prepare() {
+ local debian=($(< "${WORKDIR}"/debian/patches/series)) || die
+ debian=(${debian[@]/fdmount-compilation_linux_2.6.patch/}) # exclude this patch
+ PATCHES+=("${debian[@]/#/${WORKDIR}/debian/patches/}")
+ PATCHES+=(
+ "${FILESDIR}"/fdutils-5.5.20060227-r1-parallel.patch # bug 315577
+ "${FILESDIR}"/fdutils-5.6_p2-parallel.patch
+ "${FILESDIR}"/fdutils-5.6_p2-docs-build.patch
+ )
+ default
+}
+
+src_configure() {
+ econf --enable-fdmount-floppy-only
+}
+
+src_compile() {
+ emake
+ use doc && emake doc
+}
+
+src_install() {
+ dodir /etc
+ emake DESTDIR="${D}" install
+ emake -C doc DESTDIR="${D}" install-man
+
+ use doc && emake DESTDIR="${D}" install-doc
+
+ # The copy in sys-apps/man-pages is more recent
+ rm -f "${ED}"/usr/share/man/man4/fd.4 || die
+
+ # Rename to match binary
+ mv "${ED}"/usr/share/man/man1/{makefloppies,MAKEFLOPPIES}.1 || die
+}
diff --git a/app-misc/fdutils/files/fdutils-5.6_p2-docs-build.patch b/app-misc/fdutils/files/fdutils-5.6_p2-docs-build.patch
new file mode 100644
index 000000000000..bca3d58b5ed7
--- /dev/null
+++ b/app-misc/fdutils/files/fdutils-5.6_p2-docs-build.patch
@@ -0,0 +1,28 @@
+From 855e7727c06d6e61d0b1e3e34629de2cf0142a91 Mon Sep 17 00:00:00 2001
+From: Thomas Bracht Laumann Jespersen <t@laumann.xyz>
+Date: Wed, 2 Mar 2022 22:24:30 +0100
+Subject: [PATCH] doc: Replace CC_FOR_BUILD and EXEEXT_FOR_BUILD for building
+ docs
+
+---
+ doc/Makefile.in | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/doc/Makefile.in b/doc/Makefile.in
+index d94736f..d565359 100644
+--- a/doc/Makefile.in
++++ b/doc/Makefile.in
+@@ -37,8 +37,8 @@ INSTALL_INFO= @INSTALL_INFO@
+ CC = @CC@
+ CPPFLAGS = @CPPFLAGS@
+ CFLAGS = @CFLAGS@
+-CC_FOR_BUILD = @CC_FOR_BUILD@
+-EXEEXT_FOR_BUILD = @EXEEXT_FOR_BUILD@
++CC_FOR_BUILD = $(CC)
++EXEEXT_FOR_BUILD =
+
+ all: info dvi
+
+--
+2.34.1
+
diff --git a/app-misc/fdutils/files/fdutils-5.6_p2-parallel.patch b/app-misc/fdutils/files/fdutils-5.6_p2-parallel.patch
new file mode 100644
index 000000000000..af32199c4abb
--- /dev/null
+++ b/app-misc/fdutils/files/fdutils-5.6_p2-parallel.patch
@@ -0,0 +1,26 @@
+From 506a2cb13ce90439331b8e4e710524a040c7d0c6 Mon Sep 17 00:00:00 2001
+From: Thomas Bracht Laumann Jespersen <t@laumann.xyz>
+Date: Wed, 2 Mar 2022 12:19:35 +0100
+Subject: [PATCH] Make fdrawcmd depend on libfdutils.a
+
+This allows parallel compilation to complete successfully.
+---
+ src/Makefile.in | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/Makefile.in b/src/Makefile.in
+index b094501..5959ddf 100644
+--- a/src/Makefile.in
++++ b/src/Makefile.in
+@@ -96,7 +96,7 @@ superformat: superformat.o libfdutils.a
+ floppymeter: floppymeter.o libfdutils.a
+ ${CC} ${LDFLAGS} -o $@ $< $(LIBS)
+
+-fdrawcmd: fdrawcmd.o
++fdrawcmd: fdrawcmd.o libfdutils.a
+ ${CC} $(LDFLAGS) -o $@ $< $(LIBS)
+
+ getfdprm: getfdprm.o libfdutils.a
+--
+2.34.1
+