summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-01-01 19:53:06 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-01-01 19:53:32 +0100
commit9408d3e1b9c084949c39e5101758049f3be68b74 (patch)
tree4c48374ff5dcaa7c55405c8361324a59f08e6bb4 /app-misc/fsniper
parentsci-libs/bliss: remove old (diff)
downloadgentoo-9408d3e1b9c084949c39e5101758049f3be68b74.tar.gz
gentoo-9408d3e1b9c084949c39e5101758049f3be68b74.tar.bz2
gentoo-9408d3e1b9c084949c39e5101758049f3be68b74.zip
app-misc/fsniper: EAPI 6 bump and ebuild cleanup.
Package-Manager: portage-2.3.0
Diffstat (limited to 'app-misc/fsniper')
-rw-r--r--app-misc/fsniper/fsniper-1.3.1-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-misc/fsniper/fsniper-1.3.1-r2.ebuild b/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..d1a5f7bf1b7d
--- /dev/null
+++ b/app-misc/fsniper/fsniper-1.3.1-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Monitors a given set of directories for new files"
+HOMEPAGE="https://github.com/l3ib/fsniper/"
+SRC_URI="http://projects.l3ib.org/${PN}/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-libs/libpcre
+ sys-apps/file"
+
+RDEPEND="
+ ${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-format-security.patch
+ "${FILESDIR}"/${P}-umask.patch
+)
+
+DOCS=( AUTHORS COPYING NEWS README example.conf )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ einstalldocs
+}