summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-04-29 11:24:34 +0200
committerSam James <sam@gentoo.org>2022-05-13 20:03:38 +0000
commit05bbb798e8ac3c353a9677525a8aaddf7e936b22 (patch)
tree153a3878ba6ce6016b5193421ff0a616ab63bd41 /app-misc/g15daemon/g15daemon-9999.ebuild
parentdev-db/mydumper: bump to 0.12.1 (diff)
downloadgentoo-05bbb798e8ac3c353a9677525a8aaddf7e936b22.tar.gz
gentoo-05bbb798e8ac3c353a9677525a8aaddf7e936b22.tar.bz2
gentoo-05bbb798e8ac3c353a9677525a8aaddf7e936b22.zip
app-misc/g15daemon: [QA] properly close ebegin with eend
Each ebuild had two instances of ebegin w/o a closing eend. In one case, just add the missing eend, there's an error code can be used. In the other case, change the ebegin to einfo. Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Closes: https://github.com/gentoo/gentoo/pull/25254 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/g15daemon/g15daemon-9999.ebuild')
-rw-r--r--app-misc/g15daemon/g15daemon-9999.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/app-misc/g15daemon/g15daemon-9999.ebuild b/app-misc/g15daemon/g15daemon-9999.ebuild
index 71c34ecf83b2..472d44a00535 100644
--- a/app-misc/g15daemon/g15daemon-9999.ebuild
+++ b/app-misc/g15daemon/g15daemon-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -39,6 +39,7 @@ uinput_check() {
local rc=1
linux_config_exists && linux_chkconfig_present INPUT_UINPUT
rc=$?
+ eend ${rc}
if [[ ${rc} -ne 0 ]] ; then
eerror "To use g15daemon, you need to compile your kernel with uinput support."
@@ -137,7 +138,7 @@ src_install() {
doexe "${FILESDIR}"/20g15daemon
if use perl ; then
- ebegin "Installing Perl Bindings (G15Daemon.pm)"
+ einfo "Installing Perl Bindings (G15Daemon.pm)"
cd "${WORKDIR}/G15Daemon-0.2" || die
docinto perl
perl-module_src_install