summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/geekcode
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/geekcode')
-rw-r--r--app-misc/geekcode/Manifest1
-rw-r--r--app-misc/geekcode/files/geekcode-1.7.3-exit.patch10
-rw-r--r--app-misc/geekcode/geekcode-1.7.3-r1.ebuild31
-rw-r--r--app-misc/geekcode/metadata.xml11
4 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/geekcode/Manifest b/app-misc/geekcode/Manifest
new file mode 100644
index 000000000000..f8cc5234cc10
--- /dev/null
+++ b/app-misc/geekcode/Manifest
@@ -0,0 +1 @@
+DIST geekcode-1.7.3.tar.gz 60617 SHA256 7244972147f8855864df497f52531dbb2b3e6b9ffd2a0ce2f97e7626d166495e SHA512 eca8489dafee507246538bbb8d35cc17c5712571603bad1f470803883cdbaf9658769df77e214704b6a5adec382f76e599a2f6c48ec3759861159ac626131bfa WHIRLPOOL 4274d841946871dc42fc2c254a9b2ad2281c5650c2a3cc942ad412891980810fc2ef6a3d5a64b16ef3bb7d7fe1ee2057d7277dd1899129afa4adeb975752261e
diff --git a/app-misc/geekcode/files/geekcode-1.7.3-exit.patch b/app-misc/geekcode/files/geekcode-1.7.3-exit.patch
new file mode 100644
index 000000000000..23eba06a52eb
--- /dev/null
+++ b/app-misc/geekcode/files/geekcode-1.7.3-exit.patch
@@ -0,0 +1,10 @@
+--- geekcode.h.orig 2003-06-30 16:47:40.000000000 +0200
++++ geekcode.h 2010-12-30 19:14:51.000000000 +0100
+@@ -22,6 +22,7 @@
+ #ifndef __INCLUDED_GEEKCODE_H__
+ #define __INCLUDED_GEEKCODE_H__
+
++#include <stdlib.h> /* exit() */
+
+ #define VERSION "1.7.3" /* Added in v1.2 */
+
diff --git a/app-misc/geekcode/geekcode-1.7.3-r1.ebuild b/app-misc/geekcode/geekcode-1.7.3-r1.ebuild
new file mode 100644
index 000000000000..cd165c69042e
--- /dev/null
+++ b/app-misc/geekcode/geekcode-1.7.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Geek code generator"
+HOMEPAGE="http://sourceforge.net/projects/geekcode"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ~mips ppc ppc64 x86 ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-exit.patch
+ sed -i Makefile -e 's| -o | ${LDFLAGS}&|g' || die "sed Makefile"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin geekcode || die
+ dodoc CHANGES README geekcode.txt
+}
diff --git a/app-misc/geekcode/metadata.xml b/app-misc/geekcode/metadata.xml
new file mode 100644
index 000000000000..17d411bddcdd
--- /dev/null
+++ b/app-misc/geekcode/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">geekcode</remote-id>
+ </upstream>
+</pkgmetadata>