summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2019-07-07 20:23:32 +0300
committerMart Raudsepp <leio@gentoo.org>2019-07-07 20:29:08 +0300
commite6e1c2cbe28395f1b865a4581d309b8fbb82b31c (patch)
tree93af06ca2ee3ef4fbd0a8f293c4217d18357eb70 /app-misc/geoclue/files
parentx11-libs/gtk+: remove old (diff)
downloadgentoo-e6e1c2cbe28395f1b865a4581d309b8fbb82b31c.tar.gz
gentoo-e6e1c2cbe28395f1b865a4581d309b8fbb82b31c.tar.bz2
gentoo-e6e1c2cbe28395f1b865a4581d309b8fbb82b31c.zip
app-misc/geoclue: 2.5 series packaging fixes, unmask
* Enable demo-agent as in 2.4.13, as it's the only known agent available for non-GNOME for actually having a geoclue service responding on other desktops than GNOME * Rewrite optional vapi patch to not need sedding * Port to EAPI-7 * Add missing REQUIRED_USE="vala? ( introspection )" * Drop unnecessary bogus VALA_MIN_API_VERSION * Drop unnecessary gnome.org.eclass inherit * Fix LICENSE * Fix gtk-doc dep to be conditional to USE=gtk-doc, add missing docbook-xml-dtd dep * Reorder emesonargs to meson_options.txt order for easier (future) review and drop unnecessary backslashes at EOLs * Various other touchups * Unmask it now together with newer xdg-desktop-portal, as it's been reviewed now Closes: https://bugs.gentoo.org/678814 Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-misc/geoclue/files')
-rw-r--r--app-misc/geoclue/files/2.5.3-optional-vapi.patch52
-rw-r--r--app-misc/geoclue/files/geoclue-2.5.3-optional-vapi.patch47
2 files changed, 52 insertions, 47 deletions
diff --git a/app-misc/geoclue/files/2.5.3-optional-vapi.patch b/app-misc/geoclue/files/2.5.3-optional-vapi.patch
new file mode 100644
index 000000000000..d451d6ea6d03
--- /dev/null
+++ b/app-misc/geoclue/files/2.5.3-optional-vapi.patch
@@ -0,0 +1,52 @@
+From 3598b8b9c1a6ef4a31e2c179a6be3e3a69cce357 Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 7 Jul 2019 15:57:03 +0300
+Subject: [PATCH] meson: Make vapi generation optional and remove explicit
+ vapigen check
+
+meson gnome.generate_vapi properly handles VAPIGEN and other vala
+environment variables. It is counter-productive to check for an
+unversioned vapigen, as that breaks versioned VAPIGEN usages.
+---
+ libgeoclue/meson.build | 3 +--
+ meson_options.txt | 3 +++
+ 2 files changed, 4 insertions(+), 2 deletions(-)
+
+diff --git a/libgeoclue/meson.build b/libgeoclue/meson.build
+index e228ec3..d053bc1 100644
+--- a/libgeoclue/meson.build
++++ b/libgeoclue/meson.build
+@@ -58,7 +58,6 @@ libgeoclue_dep = declare_dependency(link_with: libgeoclue,
+ sources: [ libgeoclue_sources, libgeoclue_headers ])
+
+ gir = find_program('g-ir-scanner', required: false)
+-vapigen = find_program('vapigen', required: false)
+ enable_gir = get_option('introspection')
+ pkg_requirements = ['glib-2.0', 'gio-2.0', 'gio-unix-2.0']
+ gir_sources = [ libgeoclue_sources,
+@@ -78,7 +77,7 @@ if gir.found() and enable_gir
+ install: true,
+ header: 'geoclue.h',
+ extra_args: [ '--quiet' ])
+- if vapigen.found()
++ if get_option('vapi')
+ gnome.generate_vapi('libgeoclue-' + gclue_api_version,
+ sources: geo_gir[0],
+ packages: pkg_requirements,
+diff --git a/meson_options.txt b/meson_options.txt
+index 83bc60e..3a832d5 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -4,6 +4,9 @@ option('libgeoclue',
+ option('introspection',
+ type: 'boolean', value: true,
+ description: 'Enable convenience library introspection generation')
++option('vapi',
++ type: 'boolean', value: true,
++ description: 'Generate vapi data for convenience library (requires vapigen and introspection)')
+ option('gtk-doc',
+ type: 'boolean', value: true,
+ description: 'Whether to generate the API reference for Geocode-GLib')
+--
+2.20.1
+
diff --git a/app-misc/geoclue/files/geoclue-2.5.3-optional-vapi.patch b/app-misc/geoclue/files/geoclue-2.5.3-optional-vapi.patch
deleted file mode 100644
index 874488decace..000000000000
--- a/app-misc/geoclue/files/geoclue-2.5.3-optional-vapi.patch
+++ /dev/null
@@ -1,47 +0,0 @@
-From 56c7ca99dcadbf3e80ff2a9baf3e174f278b6a71 Mon Sep 17 00:00:00 2001
-From: Sobhan Mohammadpour <sobhan@gentoo.org>
-Date: Wed, 19 Jun 2019 01:16:16 -0400
-Subject: [PATCH] optinal vala
-
----
- libgeoclue/meson.build | 5 +++--
- meson_options.txt | 3 +++
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/libgeoclue/meson.build b/libgeoclue/meson.build
-index e228ec3..e78a3e8 100644
---- a/libgeoclue/meson.build
-+++ b/libgeoclue/meson.build
-@@ -58,7 +58,8 @@ libgeoclue_dep = declare_dependency(link_with: libgeoclue,
- sources: [ libgeoclue_sources, libgeoclue_headers ])
-
- gir = find_program('g-ir-scanner', required: false)
--vapigen = find_program('vapigen', required: false)
-+vapigen_req = get_option('vapigen')
-+vapigen = find_program('vapigen-ver', required: false)
- enable_gir = get_option('introspection')
- pkg_requirements = ['glib-2.0', 'gio-2.0', 'gio-unix-2.0']
- gir_sources = [ libgeoclue_sources,
-@@ -78,7 +79,7 @@ if gir.found() and enable_gir
- install: true,
- header: 'geoclue.h',
- extra_args: [ '--quiet' ])
-- if vapigen.found()
-+ if vapigen.found() and vapigen_req
- gnome.generate_vapi('libgeoclue-' + gclue_api_version,
- sources: geo_gir[0],
- packages: pkg_requirements,
-diff --git a/meson_options.txt b/meson_options.txt
-index 83bc60e..8611f6c 100644
---- a/meson_options.txt
-+++ b/meson_options.txt
-@@ -1,3 +1,6 @@
-+option('vapigen',
-+ type: 'boolean', value: false,
-+ description: 'Enable vala?')
- option('libgeoclue',
- type: 'boolean', value: true,
- description: 'Enable convenience library')
---
-2.21.0
-