summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2019-05-18 18:40:40 +0200
committerFabian Groffen <grobian@gentoo.org>2019-06-17 20:48:07 +0200
commit6f08eef5b16ac1157305f07540fc59484a409d65 (patch)
treedbd04042578e0c5a24fd097145a520fe110d8791 /app-misc/getopt/getopt-1.1.6-r1.ebuild
parentapp-misc/getopt: fix LICENSE, update HOMEPAGE (diff)
downloadgentoo-6f08eef5b16ac1157305f07540fc59484a409d65.tar.gz
gentoo-6f08eef5b16ac1157305f07540fc59484a409d65.tar.bz2
gentoo-6f08eef5b16ac1157305f07540fc59484a409d65.zip
app-misc/getopt: EAPI=7 bump
Closes: https://bugs.gentoo.org/686236 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: Fabian Groffen <grobian@gentoo.org>
Diffstat (limited to 'app-misc/getopt/getopt-1.1.6-r1.ebuild')
-rw-r--r--app-misc/getopt/getopt-1.1.6-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/app-misc/getopt/getopt-1.1.6-r1.ebuild b/app-misc/getopt/getopt-1.1.6-r1.ebuild
new file mode 100644
index 000000000000..0acad8e55401
--- /dev/null
+++ b/app-misc/getopt/getopt-1.1.6-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="getopt(1) replacement supporting GNU-style long options"
+HOMEPAGE="http://frodo.looijaard.name/project/getopt/"
+SRC_URI="http://frodo.looijaard.name/system/files/software/getopt/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64-fbsd ~m68k-mint ~ppc-aix ~ppc-macos ~sparc-solaris ~sparc64-solaris ~x64-cygwin ~x64-macos ~x64-solaris ~x86-fbsd ~x86-macos ~x86-solaris"
+IUSE="nls"
+
+RDEPEND="nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.5-libintl.patch
+ "${FILESDIR}"/${PN}-1.1.5-setlocale.patch
+ "${FILESDIR}"/${PN}-1.1.6-longrename.patch
+ "${FILESDIR}"/${PN}-1.1.4-irix.patch
+)
+
+src_compile() {
+ local nogettext="1"
+ local libintl=""
+ local libcgetopt=1
+
+ if use nls; then
+ nogettext=0
+ has_version sys-libs/glibc || libintl="-lintl"
+ fi
+
+ [[ ${CHOST} == *-aix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-irix* ]] && libcgetopt=0
+ [[ ${CHOST} == *-interix* ]] && libcgetopt=0
+
+ emake CC="$(tc-getCC)" prefix="${EPREFIX}/usr" \
+ LIBCGETOPT=${libcgetopt} \
+ WITHOUT_GETTEXT=${nogettext} LIBINTL=${libintl} \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ use nls && emake prefix="${EPREFIX}/usr" DESTDIR="${D}" install_po
+
+ newbin getopt getopt-long
+
+ # at least on interix, the system getopt is ... broken...
+ # util-linux, which would provide the getopt binary, does not build &
+ # install on interix/prefix, so, this has to provide it.
+ [[ ${CHOST} == *-interix* || ${CHOST} == *-mint* ]] && \
+ dosym getopt-long /usr/bin/getopt
+
+ newman getopt.1 getopt-long.1
+
+ dodoc getopt-*sh
+}