summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2018-10-07 16:57:17 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-10 23:35:36 +0100
commitad4a0ec0f342720647cf1b4f8a1c4aaeff785448 (patch)
treed66347d31b3f6670fcea7ae5c2eb9dfa264a88de /app-misc/glcdprocdriver/glcdprocdriver-0.1.2.ebuild
parentapp-misc/graphlcd-base: bump to version 1.0.1. (diff)
downloadgentoo-ad4a0ec0f342720647cf1b4f8a1c4aaeff785448.tar.gz
gentoo-ad4a0ec0f342720647cf1b4f8a1c4aaeff785448.tar.bz2
gentoo-ad4a0ec0f342720647cf1b4f8a1c4aaeff785448.zip
app-misc/glcdprocdriver: bump to version 0.1.2.
Closes: https://bugs.gentoo.org/470658 Closes: https://bugs.gentoo.org/667962 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Package-Manager: Portage-2.3.50, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/10097 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc/glcdprocdriver/glcdprocdriver-0.1.2.ebuild')
-rw-r--r--app-misc/glcdprocdriver/glcdprocdriver-0.1.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/glcdprocdriver/glcdprocdriver-0.1.2.ebuild b/app-misc/glcdprocdriver/glcdprocdriver-0.1.2.ebuild
new file mode 100644
index 000000000000..6b396bfbad4a
--- /dev/null
+++ b/app-misc/glcdprocdriver/glcdprocdriver-0.1.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="GLCDprocDriver"
+MY_P="${MY_PN}-${PV}"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A glue between the graphlcd-base library from the GraphLCD project"
+HOMEPAGE="https://lucianm.github.io/GLCDprocDriver
+ https://github.com/lucianm/GLCDprocDriver"
+SRC_URI="https://github.com/lucianm/${MY_PN}/archive/0.1.2.tar.gz -> ${MY_P}.tar.gz"
+
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=app-misc/graphlcd-base-1.0.0"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)"
+}
+
+src_install() {
+ emake DESTDIR="${ED%/}/usr" INCDIR="${ED%/}/usr/share/include" LIBDIR="${ED%/}/usr/$(get_libdir)" install
+
+ einstalldocs
+}