summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/glimpse/glimpse-4.18.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/glimpse/glimpse-4.18.5.ebuild')
-rw-r--r--app-misc/glimpse/glimpse-4.18.5.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/app-misc/glimpse/glimpse-4.18.5.ebuild b/app-misc/glimpse/glimpse-4.18.5.ebuild
new file mode 100644
index 000000000000..3fcb7ceffb99
--- /dev/null
+++ b/app-misc/glimpse/glimpse-4.18.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic eutils
+
+DESCRIPTION="A index/query system to search a large set of files quickly"
+HOMEPAGE="http://webglimpse.net/"
+SRC_URI="http://webglimpse.net/trial/${P}.tar.gz"
+
+LICENSE="glimpse"
+SLOT="0"
+KEYWORDS="alpha amd64 ia64 ~mips ppc ~ppc64 sparc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="static"
+
+RDEPEND="!dev-libs/tre
+ !app-text/agrep"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "s:CC=.*:CC=$(tc-getCC):" \
+ -e 's:-O3 -fomit-frame-pointer:$(OPTIMIZEFLAGS):' \
+ dynfilters/Makefile.in \
+ || die "removing -O3 failed"
+ sed -i \
+ -e '/^CFLAGS/s:$: $(OPTIMIZEFLAGS):' \
+ {agrep,compress,index}/Makefile.in \
+ libtemplate/{template,util}/Makefile.in \
+ || die "inserting OPTIMIZEFLAGS failed"
+ sed -i \
+ -e 's:$(mandir):&/man1/:' \
+ agrep/Makefile.in \
+ || die "adding man1 to man install dir failed"
+
+ sed -i \
+ -e '/^LDFLAGS/d' \
+ {agrep,compress,index}/Makefile.in \
+ || die "LDFLAGS sed failed"
+
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+
+ econf || die
+ emake OPTIMIZEFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ einstall || die
+}