summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2022-02-27 16:32:36 +0100
committerPatrice Clement <monsieurp@gentoo.org>2022-02-27 16:33:36 +0100
commit86c737911010bc8f582db712e4b9cca4e7a6f600 (patch)
tree64ad8c3835af8a64714fcd26745c0d60a5af5412 /app-misc/i2bits
parentsys-apps/crazydiskinfo: drop 1.1.0 (diff)
downloadgentoo-86c737911010bc8f582db712e4b9cca4e7a6f600.tar.gz
gentoo-86c737911010bc8f582db712e4b9cca4e7a6f600.tar.bz2
gentoo-86c737911010bc8f582db712e4b9cca4e7a6f600.zip
app-misc/i2bits: update EAPI 6 -> 8
Migrate to cmake.eclass whilst at it. Closes: https://bugs.gentoo.org/834314 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'app-misc/i2bits')
-rw-r--r--app-misc/i2bits/i2bits-0.1.0-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-misc/i2bits/i2bits-0.1.0-r1.ebuild b/app-misc/i2bits/i2bits-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..2e699e116f58
--- /dev/null
+++ b/app-misc/i2bits/i2bits-0.1.0-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="Utility to convert hex or dec to binary format"
+HOMEPAGE="https://bitbucket.org/PascalRD/i2bits/"
+SRC_URI="http://unixdev.ru/src/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+src_prepare() {
+ sed -e "s/^set(CMAKE_C_FLAGS.*/set(CMAKE_C_FLAGS \"${CFLAGS}\")/" \
+ -e "1s/^/project(${PN})\n/" \
+ -i CMakeLists.txt || die "can't patch CMakeLists.txt"
+
+ cmake_src_prepare
+}