summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam Jorna <wraeth@gentoo.org>2016-04-30 21:32:51 +1000
committerSam Jorna <wraeth@gentoo.org>2016-04-30 21:34:21 +1000
commitdfddec86a5787c2dc3633a0468d681126181d6a2 (patch)
tree6be98e7f6d5321e1b9938e35b527ca5c7253bb55 /app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild
parentdev-java/commons-discovery: Clean up old. (diff)
downloadgentoo-dfddec86a5787c2dc3633a0468d681126181d6a2.tar.gz
gentoo-dfddec86a5787c2dc3633a0468d681126181d6a2.tar.bz2
gentoo-dfddec86a5787c2dc3633a0468d681126181d6a2.zip
app-misc/inputlircd: revbump, fix build with headers-4.4
Introduces conditional patch for building against linux-headers-4.4, fixing a runtime issue with using unknown commands for the lirc socket. Patch and initial ebuild submitted by user Michael Cook, ebuild updated to EAPI6. Gentoo-bug: 581410 Package-Manager: portage-2.2.28
Diffstat (limited to 'app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild')
-rw-r--r--app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild b/app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild
new file mode 100644
index 000000000000..d428d3fc3758
--- /dev/null
+++ b/app-misc/inputlircd/inputlircd-0.0.1_pre15-r2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit toolchain-funcs eutils versionator
+
+DESCRIPTION="Inputlirc daemon to utilize /dev/input/event*"
+HOMEPAGE="http://svn.sliepen.eu.org/inputlirc/trunk"
+SRC_URI="http://gentooexperimental.org/~genstef/dist/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~x86"
+
+src_prepare() {
+ local ver="$(best_version sys-kernel/linux-headers)"
+ ver=${ver#sys-kernel/linux-headers-}
+ if version_is_at_least 4.4 ${ver} ; then
+ epatch "${FILESDIR}/inputlircd-linux-4.4-fix.patch"
+ fi
+
+ sed -e 's:$(CFLAGS):$(CFLAGS) $(LDFLAGS):' -i Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+
+ newinitd "${FILESDIR}"/inputlircd.init.2 inputlircd
+ newconfd "${FILESDIR}"/inputlircd.conf inputlircd
+}