summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-02-01 14:51:04 -0800
committerPatrick McLean <chutzpah@gentoo.org>2016-02-01 14:53:16 -0800
commit34ceb242b5cb7367df61c856f5e876429baa41c0 (patch)
tree1214a60d7b0d0888f7f9bcda31126a3ac6dce3bf /app-misc/jq/jq-1.5-r1.ebuild
parentmedia-sound/bpmdetect: Port to scons-utils.eclass (diff)
downloadgentoo-34ceb242b5cb7367df61c856f5e876429baa41c0.tar.gz
gentoo-34ceb242b5cb7367df61c856f5e876429baa41c0.tar.bz2
gentoo-34ceb242b5cb7367df61c856f5e876429baa41c0.zip
app-misc/jq: Revision bump, update bison dep to >=3.0 add rdep on oniguruma
Gentoo-Bug: 573058 Package-Manager: portage-2.2.27
Diffstat (limited to 'app-misc/jq/jq-1.5-r1.ebuild')
-rw-r--r--app-misc/jq/jq-1.5-r1.ebuild53
1 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/jq/jq-1.5-r1.ebuild b/app-misc/jq/jq-1.5-r1.ebuild
new file mode 100644
index 000000000000..df24e2f78f45
--- /dev/null
+++ b/app-misc/jq/jq-1.5-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A lightweight and flexible command-line JSON processor"
+HOMEPAGE="https://stedolan.github.com/jq/"
+SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x64-macos"
+IUSE="oniguruma static-libs test"
+
+DEPEND=">=sys-devel/bison-3.0
+ sys-devel/flex
+ oniguruma? ( dev-libs/oniguruma[static-libs?] )
+ test? ( dev-util/valgrind )"
+RDEPEND="!static-libs? (
+ oniguruma? ( dev-libs/oniguruma[static-libs?] )
+ )"
+
+DOCS=( AUTHORS README )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.5-dynamic-link.patch
+ "${FILESDIR}"/${P}-remove-automagic-dep-on-oniguruma.patch
+)
+
+src_prepare() {
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ sed -i -r "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # don't try to rebuild docs
+ econf \
+ --disable-docs \
+ $(use_enable static-libs static) \
+ $(use_with oniguruma)
+}
+
+src_install() {
+ default
+ use static-libs || find "${ED}" -name libjq.la -delete
+}