summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2019-04-12 14:06:46 -0700
committerPatrick McLean <chutzpah@gentoo.org>2019-04-12 14:07:47 -0700
commit0d6f69a4b08c32aec8e8c65f48cc6d75274830d1 (patch)
tree224b097a88b6505ef0d90d0f402ab8e9ea23331c /app-misc/jq/jq-1.6-r3.ebuild
parentdev-python/ipaddress: arm64 stable (bug #680858) (diff)
downloadgentoo-0d6f69a4b08c32aec8e8c65f48cc6d75274830d1.tar.gz
gentoo-0d6f69a4b08c32aec8e8c65f48cc6d75274830d1.tar.bz2
gentoo-0d6f69a4b08c32aec8e8c65f48cc6d75274830d1.zip
app-misc/jq: Revbump, fix oniguruma patch (bug #674680)
Patch by Robin Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/674680 Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'app-misc/jq/jq-1.6-r3.ebuild')
-rw-r--r--app-misc/jq/jq-1.6-r3.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-misc/jq/jq-1.6-r3.ebuild b/app-misc/jq/jq-1.6-r3.ebuild
new file mode 100644
index 000000000000..2b187f05c7ab
--- /dev/null
+++ b/app-misc/jq/jq-1.6-r3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A lightweight and flexible command-line JSON processor"
+HOMEPAGE="https://stedolan.github.com/jq/"
+SRC_URI="https://github.com/stedolan/jq/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="MIT CC-BY-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x64-macos"
+IUSE="oniguruma static-libs"
+
+DEPEND="
+ >=sys-devel/bison-3.0
+ sys-devel/flex
+ oniguruma? ( dev-libs/oniguruma:=[static-libs?] )
+"
+RDEPEND="
+ !static-libs? (
+ oniguruma? ( dev-libs/oniguruma[static-libs?] )
+ )
+"
+
+src_prepare() {
+ local PATCHES=(
+ "${FILESDIR}"/jq-1.6-r3-never-bundle-oniguruma.patch
+ "${FILESDIR}"/jq-1.6-runpath.patch
+ "${FILESDIR}"/jq-1.6-segfault-fix.patch
+ )
+ use oniguruma || { sed -i 's:tests/onigtest::' Makefile.am || die; }
+ sed -i '/^dist_doc_DATA/d' Makefile.am || die
+ sed -i -r "s:(m4_define\(\[jq_version\],) .+\):\1 \[${PV}\]):" \
+ configure.ac || die
+
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ # don't try to rebuild docs
+ --disable-docs
+ --disable-valgrind
+ --disable-maintainer-mode
+ --enable-rpathhack
+ $(use_enable static-libs static)
+ $(use_with oniguruma oniguruma yes)
+ )
+ econf "${econfargs[@]}"
+}
+
+src_install() {
+ local DOCS=( AUTHORS README.md )
+ default
+
+ use static-libs || { find "${D}" -name '*.la' -delete || die; }
+}