summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-02-21 16:13:15 +0100
committerAmy Winston <amynka@gentoo.org>2016-02-21 16:17:23 +0100
commitc122ded892bf5a3e75c49bd3ce58f76c6f09156a (patch)
treef65fcc4ac542e6595b6ce0c7d1c82b6f1ea89679 /app-misc/khal/khal-0.7.0.ebuild
parentdev-python/vdirsyncer: Initial commit dependency for khal (diff)
downloadgentoo-c122ded892bf5a3e75c49bd3ce58f76c6f09156a.tar.gz
gentoo-c122ded892bf5a3e75c49bd3ce58f76c6f09156a.tar.bz2
gentoo-c122ded892bf5a3e75c49bd3ce58f76c6f09156a.zip
app-misc/khal: Initial commit new package bug #550998
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-misc/khal/khal-0.7.0.ebuild')
-rw-r--r--app-misc/khal/khal-0.7.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.7.0.ebuild b/app-misc/khal/khal-0.7.0.ebuild
new file mode 100644
index 000000000000..a720dac58a72
--- /dev/null
+++ b/app-misc/khal/khal-0.7.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/vdirsyncer[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.txt README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}