summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmy Winston <amynka@gentoo.org>2016-04-23 22:19:53 +0200
committerAmy Winston <amynka@gentoo.org>2016-04-23 22:19:53 +0200
commiteed6c7055eca33f09abe1669e53ad64edecbcbf8 (patch)
treee24956dc17b1a8ecef07f01dc42ad2ae4aa78167 /app-misc/khal/khal-0.8.1.ebuild
parentsys-fs/ext4magic: Fixes maintainer's name. (diff)
downloadgentoo-eed6c7055eca33f09abe1669e53ad64edecbcbf8.tar.gz
gentoo-eed6c7055eca33f09abe1669e53ad64edecbcbf8.tar.bz2
gentoo-eed6c7055eca33f09abe1669e53ad64edecbcbf8.zip
app-misc/khal: version bump 0.8.1 bug #580904
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-misc/khal/khal-0.8.1.ebuild')
-rw-r--r--app-misc/khal/khal-0.8.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-misc/khal/khal-0.8.1.ebuild b/app-misc/khal/khal-0.8.1.ebuild
new file mode 100644
index 000000000000..72c80aa87310
--- /dev/null
+++ b/app-misc/khal/khal-0.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+
+PYTHON_COMPAT=( python3_{3,4} )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1
+
+DESCRIPTION="A CalDAV based calendar"
+HOMEPAGE="http://lostpackets.de/khal/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+SLOT="0"
+IUSE="zsh-completion"
+
+RDEPEND=">=dev-python/click-3.2[${PYTHON_USEDEP}]
+ dev-python/icalendar[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/vdirsyncer-0.5.2[${PYTHON_USEDEP}]
+ dev-python/pkginfo[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ zsh-completion? ( app-shells/zsh )"
+
+DEPEND="dev-python/setuptools_scm[${PYTHON_USEDEP}]"
+
+DOCS=( AUTHORS.txt CHANGELOG.rst CONTRIBUTING.txt README.rst khal.conf.sample )
+
+src_install() {
+ distutils-r1_src_install
+ if use zsh-completion; then
+ insinto /usr/share/zsh/site-functions
+ doins misc/__khal
+ fi
+}