summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2020-08-03 09:23:35 +0200
committerHanno Böck <hanno@gentoo.org>2020-08-03 09:23:35 +0200
commitb74fbfd59f8533e7c59af6fe033f4bc85fe70255 (patch)
treeb7ca5d70ec37574a2168fa7a40bca106f61dae5d /app-misc/ktoblzcheck
parentdev-haskell/editline: tweak for cabal-3 (diff)
downloadgentoo-b74fbfd59f8533e7c59af6fe033f4bc85fe70255.tar.gz
gentoo-b74fbfd59f8533e7c59af6fe033f4bc85fe70255.tar.bz2
gentoo-b74fbfd59f8533e7c59af6fe033f4bc85fe70255.zip
app-misc/ktoblzcheck: Disable Python.
Python code is python 2 only, no other package uses it. Bug: https://bugs.gentoo.org/735228 Signed-off-by: Hanno Böck <hanno@gentoo.org> Package-Manager: Portage-3.0.1, Repoman-2.3.23
Diffstat (limited to 'app-misc/ktoblzcheck')
-rw-r--r--app-misc/ktoblzcheck/ktoblzcheck-1.49-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-misc/ktoblzcheck/ktoblzcheck-1.49-r2.ebuild b/app-misc/ktoblzcheck/ktoblzcheck-1.49-r2.ebuild
new file mode 100644
index 000000000000..70b76b0106e5
--- /dev/null
+++ b/app-misc/ktoblzcheck/ktoblzcheck-1.49-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Library to check account numbers and bank codes of German banks"
+HOMEPAGE="http://ktoblzcheck.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="
+ app-text/recode:0=
+ sys-apps/grep
+ sys-apps/sed
+ virtual/awk
+ || ( net-misc/wget www-client/lynx )
+"
+DEPEND="${RDEPEND}
+ sys-devel/libtool
+"
+
+DOCS=( AUTHORS ChangeLog NEWS README )
+
+src_configure() {
+ econf --disable-python
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}