summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2023-03-22 22:56:54 +0000
committerMarek Szuba <marecki@gentoo.org>2023-03-22 23:43:32 +0000
commitba78d4f642d6ab7e287b45cbc6ecae872d45dcfd (patch)
tree06769ba2cde06dbbe020904d15df6df1f8ddfb65 /app-misc/mc
parentnet-misc/oidc-agent: drop 4.4.0, 4.5.0 (diff)
downloadgentoo-ba78d4f642d6ab7e287b45cbc6ecae872d45dcfd.tar.gz
gentoo-ba78d4f642d6ab7e287b45cbc6ecae872d45dcfd.tar.bz2
gentoo-ba78d4f642d6ab7e287b45cbc6ecae872d45dcfd.zip
app-misc/mc: fix implicit function declaration in configure
Closes: https://bugs.gentoo.org/900475 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-misc/mc')
-rw-r--r--app-misc/mc/files/mc-4.8.29-autoconf-c99.patch24
-rw-r--r--app-misc/mc/mc-4.8.29.ebuild1
2 files changed, 25 insertions, 0 deletions
diff --git a/app-misc/mc/files/mc-4.8.29-autoconf-c99.patch b/app-misc/mc/files/mc-4.8.29-autoconf-c99.patch
new file mode 100644
index 000000000000..f1577dd7abbc
--- /dev/null
+++ b/app-misc/mc/files/mc-4.8.29-autoconf-c99.patch
@@ -0,0 +1,24 @@
+From a2dbad461b8a63630f9ad7cfa36b6613e85a91cb Mon Sep 17 00:00:00 2001
+From: Florian Weimer <fweimer@redhat.com>
+Date: Sun, 5 Feb 2023 18:38:37 +0100
+Subject: [PATCH] autoconf: Fix C99 compatibility issue in mc_GET_FS_INFO check
+Content-type: text/plain
+
+Include <fcntl.h> for the declaration of posix_fallocate. This
+avoids an implicit function declaration and build issues with future
+compilers.
+
+Signed-off-by: Florian Weimer <fweimer@redhat.com>
+--- a/m4.include/mc-get-fs-info.m4
++++ b/m4.include/mc-get-fs-info.m4
+@@ -8,6 +8,7 @@ AC_DEFUN([gl_POSIX_FALLOCATE], [
+ AC_LINK_IFELSE([AC_LANG_PROGRAM([[
+ #define _XOPEN_SOURCE 600
+ #include <stdlib.h>
++ #include <fcntl.h>
+ #if defined(__GLIBC__) && (__GLIBC__ < 2 || __GLIBC_MINOR__ < 7)
+ possibly broken posix_fallocate
+ #endif
+--
+2.39.1
+
diff --git a/app-misc/mc/mc-4.8.29.ebuild b/app-misc/mc/mc-4.8.29.ebuild
index e24016e2177e..7604d402b276 100644
--- a/app-misc/mc/mc-4.8.29.ebuild
+++ b/app-misc/mc/mc-4.8.29.ebuild
@@ -50,6 +50,7 @@ S="${WORKDIR}/${MY_P}"
PATCHES=(
"${FILESDIR}"/${PN}-4.8.26-ncurses-mouse.patch
"${FILESDIR}"/${PN}-4.8.29-gentoo-tools.patch
+ "${FILESDIR}"/${PN}-4.8.29-autoconf-c99.patch
)
src_prepare() {