summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-09-19 19:15:27 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-09-19 19:15:27 +0200
commit02a731317220f5fd4b70d875123cac4bee216ece (patch)
tree50394d1fd34cdaa760739e268c4fd07df2a4615f /app-misc/media-player-info/media-player-info-23.ebuild
parentx11-misc/shared-mime-info: Version bump to 1.9 (diff)
downloadgentoo-02a731317220f5fd4b70d875123cac4bee216ece.tar.gz
gentoo-02a731317220f5fd4b70d875123cac4bee216ece.tar.bz2
gentoo-02a731317220f5fd4b70d875123cac4bee216ece.zip
app-misc/media-player-info: Version bump to 23
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'app-misc/media-player-info/media-player-info-23.ebuild')
-rw-r--r--app-misc/media-player-info/media-player-info-23.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-misc/media-player-info/media-player-info-23.ebuild b/app-misc/media-player-info/media-player-info-23.ebuild
new file mode 100644
index 000000000000..24e2cf1b615c
--- /dev/null
+++ b/app-misc/media-player-info/media-player-info-23.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit eutils python-any-r1
+
+DESCRIPTION="A repository of data files describing media player capabilities"
+HOMEPAGE="https://cgit.freedesktop.org/media-player-info/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+# https://cgit.freedesktop.org/media-player-info/commit/?id=d83dd01a0a1df6198ee08954da1c033b88a1004b
+RDEPEND=">=virtual/udev-208"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+pkg_postinst() {
+ # Run for /lib/udev/hwdb.d/20-usb-media-players.hwdb
+ udevadm hwdb --update --root="${ROOT%/}"
+ # https://cgit.freedesktop.org/systemd/systemd/commit/?id=1fab57c209035f7e66198343074e9cee06718bda
+ if [[ ${ROOT} != "" ]] && [[ ${ROOT} != "/" ]]; then
+ return 0
+ fi
+ udevadm control --reload
+}