summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/mediacrush-cli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/mediacrush-cli')
-rw-r--r--app-misc/mediacrush-cli/Manifest1
-rw-r--r--app-misc/mediacrush-cli/mediacrush-cli-1.1.2.ebuild46
-rw-r--r--app-misc/mediacrush-cli/mediacrush-cli-9999.ebuild45
-rw-r--r--app-misc/mediacrush-cli/metadata.xml11
4 files changed, 103 insertions, 0 deletions
diff --git a/app-misc/mediacrush-cli/Manifest b/app-misc/mediacrush-cli/Manifest
new file mode 100644
index 000000000000..374ae634efe6
--- /dev/null
+++ b/app-misc/mediacrush-cli/Manifest
@@ -0,0 +1 @@
+DIST mediacrush-cli-1.1.2.tar.gz 3299 SHA256 eaa8f7f7999246bc5cb2fb356cfb35263009b5a0f386000488e638e81fb5a72a SHA512 fa4c905e75ffe1d16a83a6c3cc29dd2e28eb9097d1bc95742ece2356ab6e219c15c75bab7a09443c98b18e438d1e6690968d24c35eb7a3dd0877dff36574761c WHIRLPOOL 3614a7afacb6edcfd7c589f0bbe2769143c0a3638331d0b64c2e25f2d2b0fe89c32c1281e91da4ca315df3f8b9e15a47009e9bcb6d750721ec98345cdac4ed76
diff --git a/app-misc/mediacrush-cli/mediacrush-cli-1.1.2.ebuild b/app-misc/mediacrush-cli/mediacrush-cli-1.1.2.ebuild
new file mode 100644
index 000000000000..647c55768664
--- /dev/null
+++ b/app-misc/mediacrush-cli/mediacrush-cli-1.1.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/MediaCrush/MediaCrush-cli.git"
+ SRC_URI=""
+ KEYWORDS=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/MediaCrush/MediaCrush-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/MediaCrush-cli-${PV}"
+fi
+
+DESCRIPTION="A bash script for working with MediaCrush from a shell"
+HOMEPAGE="https://github.com/MediaCrush/MediaCrush-cli"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/asciidoc
+"
+RDEPEND="
+ app-editors/vim-core
+ net-misc/curl
+ sys-apps/file
+ sys-apps/sed
+"
+
+src_compile() {
+ a2x --doctype manpage --format manpage mediacrush.1.txt
+}
+
+src_install() {
+ dobin mediacrush
+ doman mediacrush.1
+
+ if ! has_version x11-misc/xdg-utils; then
+ einfo "Install x11-misc/xdg-utils to enable '--open' argument"
+ fi
+}
diff --git a/app-misc/mediacrush-cli/mediacrush-cli-9999.ebuild b/app-misc/mediacrush-cli/mediacrush-cli-9999.ebuild
new file mode 100644
index 000000000000..4df6a7c4320b
--- /dev/null
+++ b/app-misc/mediacrush-cli/mediacrush-cli-9999.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="git://github.com/MediaCrush/MediaCrush-cli.git"
+ SRC_URI=""
+ KEYWORDS=""
+ inherit git-r3
+else
+ SRC_URI="https://github.com/MediaCrush/MediaCrush-cli/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/MediaCrush-cli-${PV}"
+fi
+
+DESCRIPTION="A bash script for working with MediaCrush from a shell"
+HOMEPAGE="https://github.com/MediaCrush/MediaCrush-cli"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ app-text/asciidoc
+"
+RDEPEND="
+ net-misc/curl
+ sys-apps/file
+ sys-apps/sed
+"
+
+src_compile() {
+ a2x --doctype manpage --format manpage mediacrush.1.txt
+}
+
+src_install() {
+ dobin mediacrush
+ doman mediacrush.1
+
+ if ! has_version x11-misc/xdg-utils; then
+ einfo "Install x11-misc/xdg-utils to enable '--open' argument"
+ fi
+}
diff --git a/app-misc/mediacrush-cli/metadata.xml b/app-misc/mediacrush-cli/metadata.xml
new file mode 100644
index 000000000000..0902c6843253
--- /dev/null
+++ b/app-misc/mediacrush-cli/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">MediaCrush/MediaCrush-cli</remote-id>
+ </upstream>
+</pkgmetadata>