summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@gentoo.org>2019-01-08 09:16:15 -0500
committerCraig Andrews <candrews@gentoo.org>2019-01-08 09:38:30 -0500
commita75596f23be965f992efdd08d698637abe74c5bd (patch)
tree27542f369d2324523c9c5631775e39bbe4ac2338 /app-misc/neofetch
parentnet-misc/curl: generalise darwin fixes (diff)
downloadgentoo-a75596f23be965f992efdd08d698637abe74c5bd.tar.gz
gentoo-a75596f23be965f992efdd08d698637abe74c5bd.tar.bz2
gentoo-a75596f23be965f992efdd08d698637abe74c5bd.zip
app-misc/neofetch: 5.1.0 version bump
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'app-misc/neofetch')
-rw-r--r--app-misc/neofetch/Manifest1
-rw-r--r--app-misc/neofetch/neofetch-5.1.0.ebuild28
-rw-r--r--app-misc/neofetch/neofetch-9999.ebuild4
3 files changed, 31 insertions, 2 deletions
diff --git a/app-misc/neofetch/Manifest b/app-misc/neofetch/Manifest
index 1746df1690fe..8ed811daf21a 100644
--- a/app-misc/neofetch/Manifest
+++ b/app-misc/neofetch/Manifest
@@ -1 +1,2 @@
DIST neofetch-5.0.0.tar.gz 110526 BLAKE2B 7149321c051021644407d28b232631c8149d21f1b8463b3a4470d1baaf88494f3a88026c606ac539938933333da5671f4a14b6ce029268ba01a16e85d4a30c33 SHA512 7872e646a0d784d0c9d851d16cb1ef03926d07f67ec9573b673b2a82fd9a1ffbb7bbcb0ca0e67c299dd210947396a8c36dacb98d8a61c3ea72b5a438995e7de6
+DIST neofetch-5.1.0.tar.gz 115531 BLAKE2B 386544311fb3a46571791a7c61ee4657e155912add68172dd2c9fa59d6deb0f246b2a0880e00c31c422781ae765fe555c3f82aa2e7f93606419b2cd49f69a902 SHA512 a30ec9c0b5971f89e487a3d7f5a09b3a379cf2c1770abed82efcf2943dcea2640786d4adb276b3125e161bdf3aedee1549dd82ff05addb061479e5dc9afe99d7
diff --git a/app-misc/neofetch/neofetch-5.1.0.ebuild b/app-misc/neofetch/neofetch-5.1.0.ebuild
new file mode 100644
index 000000000000..45192c9d63c8
--- /dev/null
+++ b/app-misc/neofetch/neofetch-5.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~mips ~x86 ~amd64-fbsd"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"
+fi
+
+DESCRIPTION="Simple information system script"
+HOMEPAGE="https://github.com/dylanaraps/neofetch"
+LICENSE="MIT-with-advertising"
+SLOT="0"
+IUSE="X"
+
+RDEPEND="sys-apps/pciutils
+ X? (
+ media-gfx/imagemagick
+ media-libs/imlib2
+ www-client/w3m[imlib]
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ )"
diff --git a/app-misc/neofetch/neofetch-9999.ebuild b/app-misc/neofetch/neofetch-9999.ebuild
index 4757864917ab..45192c9d63c8 100644
--- a/app-misc/neofetch/neofetch-9999.ebuild
+++ b/app-misc/neofetch/neofetch-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
if [[ ${PV} != *9999* ]]; then
SRC_URI="https://github.com/dylanaraps/${PN}/archive/${PV}/${P}.tar.gz"
- KEYWORDS="~amd64 ~x86 ~amd64-fbsd"
+ KEYWORDS="~amd64 ~mips ~x86 ~amd64-fbsd"
else
inherit git-r3
EGIT_REPO_URI="https://github.com/dylanaraps/neofetch.git"