summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-05-08 15:19:51 -0700
committerMichał Górny <mgorny@gentoo.org>2017-05-11 20:25:23 +0200
commitde6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0 (patch)
tree4273f2c00eab3ef7ee631bd5f6d745bec1f8d427 /app-misc/openastro/openastro-1.1.49.ebuild
parentapp-misc/openastro-data: version bump to 1.7 (diff)
downloadgentoo-de6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0.tar.gz
gentoo-de6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0.tar.bz2
gentoo-de6e62e2a0b19c7f5eb8572eb98387f54c1a0aa0.zip
app-misc/openastro: version bump to 1.1.49
Closes: https://github.com/gentoo/gentoo/pull/4575
Diffstat (limited to 'app-misc/openastro/openastro-1.1.49.ebuild')
-rw-r--r--app-misc/openastro/openastro-1.1.49.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/openastro/openastro-1.1.49.ebuild b/app-misc/openastro/openastro-1.1.49.ebuild
new file mode 100644
index 000000000000..142482203fa1
--- /dev/null
+++ b/app-misc/openastro/openastro-1.1.49.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN=${PN}.org
+
+DESCRIPTION="A fully-featured Open Source Astrology Program"
+HOMEPAGE="http://openastro.org"
+SRC_URI="http://ppa.launchpad.net/pellesimon/ubuntu/pool/main/o/${MY_PN}/${MY_PN}_${PV}.orig.tar.gz"
+KEYWORDS="~amd64 ~x86"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+IUSE="jpeg png"
+
+DEPEND="
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/pycairo[svg,${PYTHON_USEDEP}]
+ dev-python/librsvg-python[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyswisseph[${PYTHON_USEDEP}]
+ app-misc/openastro-data[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+ jpeg? ( media-gfx/imagemagick[jpeg,svg] )
+ png? ( media-gfx/imagemagick[png,svg] )"
+
+S=${WORKDIR}/${MY_PN}-${PV}