summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-09-19 02:26:29 -0400
committerMike Frysinger <vapier@gentoo.org>2015-09-19 02:26:29 -0400
commit5cb4ae639035b227110e2410ac353f4199a698d1 (patch)
tree778738ee08f09106dcad19afff481782fcee2012 /app-misc/pax-utils/pax-utils-1.1.3.ebuild
parentmedia-tv/kodi: run the codegenerator when USE=java #558798 (diff)
downloadgentoo-5cb4ae639035b227110e2410ac353f4199a698d1.tar.gz
gentoo-5cb4ae639035b227110e2410ac353f4199a698d1.tar.bz2
gentoo-5cb4ae639035b227110e2410ac353f4199a698d1.zip
app-misc/pax-utils: version bump to 1.1.3
Diffstat (limited to 'app-misc/pax-utils/pax-utils-1.1.3.ebuild')
-rw-r--r--app-misc/pax-utils/pax-utils-1.1.3.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/app-misc/pax-utils/pax-utils-1.1.3.ebuild b/app-misc/pax-utils/pax-utils-1.1.3.ebuild
new file mode 100644
index 000000000000..fc7931905711
--- /dev/null
+++ b/app-misc/pax-utils/pax-utils-1.1.3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit eutils toolchain-funcs unpacker
+
+DESCRIPTION="ELF related utils for ELF 32/64 binaries that can check files for security relevant properties"
+HOMEPAGE="https://wiki.gentoo.org/index.php?title=Project:Hardened/PaX_Utilities"
+SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~solar/pax/${P}.tar.xz
+ http://dev.gentoo.org/~vapier/dist/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+IUSE="caps debug python seccomp"
+
+RDEPEND="caps? ( >=sys-libs/libcap-2.24 )
+ python? ( dev-python/pyelftools )
+ seccomp? ( sys-libs/libseccomp )"
+DEPEND="${RDEPEND}
+ caps? ( virtual/pkgconfig )
+ seccomp? ( virtual/pkgconfig )
+ app-arch/xz-utils"
+
+_emake() {
+ emake \
+ USE_CAP=$(usex caps) \
+ USE_DEBUG=$(usex debug) \
+ USE_PYTHON=$(usex python) \
+ USE_SECCOMP=$(usex seccomp) \
+ "$@"
+}
+
+src_configure() {
+ # Avoid slow configure+gnulib+make if on an up-to-date Linux system
+ if use prefix || ! use kernel_linux || \
+ has_version '<sys-libs/glibc-2.10'
+ then
+ econf $(use_with caps) $(use_with debug) $(use_with python) $(use_with seccomp)
+ else
+ tc-export CC
+ fi
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ _emake check
+}
+
+src_install() {
+ _emake DESTDIR="${ED}" PKGDOCDIR='$(DOCDIR)'/${PF} install
+}