summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-01-10 23:38:06 -0500
committerTim Harder <radhermit@gentoo.org>2016-01-10 23:38:06 -0500
commit7a5e807ee68b275311d1c04abc64c9882c3ddac4 (patch)
tree0d52b3ef9d53fe4dd1b4760e25bfce7ae1d36d01 /app-misc/physlock/physlock-0.5.ebuild
parentapp-misc/dateutils: version bump to 0.3.4 (diff)
downloadgentoo-7a5e807ee68b275311d1c04abc64c9882c3ddac4.tar.gz
gentoo-7a5e807ee68b275311d1c04abc64c9882c3ddac4.tar.bz2
gentoo-7a5e807ee68b275311d1c04abc64c9882c3ddac4.zip
app-misc/physlock: version bump to 0.5
Diffstat (limited to 'app-misc/physlock/physlock-0.5.ebuild')
-rw-r--r--app-misc/physlock/physlock-0.5.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/app-misc/physlock/physlock-0.5.ebuild b/app-misc/physlock/physlock-0.5.ebuild
new file mode 100644
index 000000000000..aaf000a32ba9
--- /dev/null
+++ b/app-misc/physlock/physlock-0.5.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="lightweight Linux console locking tool"
+HOMEPAGE="https://github.com/muennich/physlock"
+SRC_URI="https://github.com/muennich/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+src_prepare() {
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX=/usr install
+}