summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/pipeworks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/pipeworks')
-rw-r--r--app-misc/pipeworks/Manifest1
-rw-r--r--app-misc/pipeworks/metadata.xml15
-rw-r--r--app-misc/pipeworks/pipeworks-0.4.ebuild26
3 files changed, 42 insertions, 0 deletions
diff --git a/app-misc/pipeworks/Manifest b/app-misc/pipeworks/Manifest
new file mode 100644
index 000000000000..0b6077650f02
--- /dev/null
+++ b/app-misc/pipeworks/Manifest
@@ -0,0 +1 @@
+DIST pipeworks-0.4.tar.gz 11560 SHA256 8360164e11f53f0cd84e9a4c0c11fcd951767ea0afd256537131fbc42ec51466 SHA512 ddd9875deab26d0f0b673846c7838733a2c3ec573fbd06d85e4058adb3b0d5274daeac1165b573743b8b3da6aa05c24b9ecc0ac788b24a42cf0f379a8eb56ebd WHIRLPOOL 4fb1e6ec0fd4d7a30481e6aa642083b1205620f8fe5c185b698d3cf2ab82f7b2cf0ee3e59f12fb47590ed9e21448eced4385e50b1882a4ed9ce88fa014c9def9
diff --git a/app-misc/pipeworks/metadata.xml b/app-misc/pipeworks/metadata.xml
new file mode 100644
index 000000000000..05d609b8e207
--- /dev/null
+++ b/app-misc/pipeworks/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+pipeworks is a benchmarking tool for pipelines that is very similar to pipemeter. It writes its stdin to its
+stdout, while reporting the data flow rate to stderr. It features adjustable block size and bandwidth limiting
+capabilities.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">pipeworks</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-misc/pipeworks/pipeworks-0.4.ebuild b/app-misc/pipeworks/pipeworks-0.4.ebuild
new file mode 100644
index 000000000000..b882e0707722
--- /dev/null
+++ b/app-misc/pipeworks/pipeworks-0.4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit toolchain-funcs
+
+DESCRIPTION="a small utility that measures throughput between stdin and stdout"
+HOMEPAGE="http://pipeworks.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pipeworks/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DEPEND=""
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS} ${LDFLAGS}" || die "emake failed"
+}
+
+src_install() {
+ dobin pipeworks || die "dobin failed"
+ doman pipeworks.1
+ dodoc Changelog README
+}