summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 04:27:31 +0000
committerSam James <sam@gentoo.org>2021-04-19 04:30:58 +0000
commit48925b0e5a636181798cf8100b796f2236a8bc3c (patch)
tree70666ddbc870424af8bd42cb0826562de80f30a8 /app-misc/realpath
parentapp-misc/hddled: port to EAPI 7 (diff)
downloadgentoo-48925b0e5a636181798cf8100b796f2236a8bc3c.tar.gz
gentoo-48925b0e5a636181798cf8100b796f2236a8bc3c.tar.bz2
gentoo-48925b0e5a636181798cf8100b796f2236a8bc3c.zip
app-misc/realpath: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-misc/realpath')
-rw-r--r--app-misc/realpath/files/realpath-1.14-no-po4a.patch4
-rw-r--r--app-misc/realpath/files/realpath-1.15-prefix.patch2
-rw-r--r--app-misc/realpath/files/realpath-1.16-nonls.patch5
-rw-r--r--app-misc/realpath/realpath-1.18.ebuild34
4 files changed, 25 insertions, 20 deletions
diff --git a/app-misc/realpath/files/realpath-1.14-no-po4a.patch b/app-misc/realpath/files/realpath-1.14-no-po4a.patch
index cfa780553646..44e13286bfac 100644
--- a/app-misc/realpath/files/realpath-1.14-no-po4a.patch
+++ b/app-misc/realpath/files/realpath-1.14-no-po4a.patch
@@ -1,8 +1,8 @@
Don't require po4a at build time.
http://bugs.gentoo.org/269905
---- realpath-1.14-orig/po/Makefile 2009-02-22 12:56:47.000000000 +0100
-+++ realpath-1.14/po/Makefile 2009-05-19 23:45:26.000000000 +0200
+--- a/po/Makefile
++++ b/po/Makefile
@@ -4,5 +4,5 @@
#
diff --git a/app-misc/realpath/files/realpath-1.15-prefix.patch b/app-misc/realpath/files/realpath-1.15-prefix.patch
index f9534641382f..3e0837a8bf38 100644
--- a/app-misc/realpath/files/realpath-1.15-prefix.patch
+++ b/app-misc/realpath/files/realpath-1.15-prefix.patch
@@ -1,5 +1,3 @@
-diff --git a/common.mk b/common.mk
-index 2443a40..0a342ee 100644
--- a/common.mk
+++ b/common.mk
@@ -8,17 +8,19 @@ override TOPDIR := $(dir $(call getCurrentMakefileName))
diff --git a/app-misc/realpath/files/realpath-1.16-nonls.patch b/app-misc/realpath/files/realpath-1.16-nonls.patch
index d758d03ff89b..c1963ae46014 100644
--- a/app-misc/realpath/files/realpath-1.16-nonls.patch
+++ b/app-misc/realpath/files/realpath-1.16-nonls.patch
@@ -1,8 +1,3 @@
- src/realpath.c | 6 +-----
- 1 files changed, 1 insertions(+), 5 deletions(-)
-
-diff --git a/src/realpath.c b/src/realpath.c
-index 76fc909..e2cf86f 100644
--- a/src/realpath.c
+++ b/src/realpath.c
@@ -23,10 +23,9 @@
diff --git a/app-misc/realpath/realpath-1.18.ebuild b/app-misc/realpath/realpath-1.18.ebuild
index 0a61456cc83e..c982935ecdbd 100644
--- a/app-misc/realpath/realpath-1.18.ebuild
+++ b/app-misc/realpath/realpath-1.18.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit epatch flag-o-matic prefix
+inherit flag-o-matic prefix
DESCRIPTION="Return the canonicalized absolute pathname"
HOMEPAGE="http://packages.debian.org/unstable/utils/realpath"
@@ -18,9 +18,16 @@ IUSE="nls"
RDEPEND="
nls? ( virtual/libintl )"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
nls? ( sys-devel/gettext )
- elibc_mintlib? ( virtual/libiconv )"
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.17-build.patch
+ "${FILESDIR}"/${PN}-1.14-no-po4a.patch
+ "${FILESDIR}"/${PN}-1.15-prefix.patch
+)
src_unpack() {
unpack ${PN}_${PV}.tar.gz
@@ -36,18 +43,22 @@ src_unpack() {
}
src_prepare() {
- use nls || epatch "${FILESDIR}"/${PN}-1.16-nonls.patch
- epatch \
- "${FILESDIR}"/${PN}-1.17-build.patch \
- "${FILESDIR}"/${PN}-1.14-no-po4a.patch \
- "${FILESDIR}"/${PN}-1.15-prefix.patch
+ if ! use nls ; then
+ eapply "${FILESDIR}"/${PN}-1.16-nonls.patch
+ fi
+
+ default
+
+ # Don't compress man pages
+ sed -i -e 's:gzip -9f:true:' common.mk || die
+
eprefixify common.mk
}
src_compile() {
tc-export CC
+
use nls && ! use elibc_glibc && append-libs -lintl
- [[ ${CHOST} == *-mint* ]] && append-libs "-liconv"
local subdir
for subdir in src man $(usex nls po ''); do
@@ -61,12 +72,13 @@ src_install() {
SUBDIRS="src man $(usex nls po '')" \
DESTDIR="${D}" \
install
+
newdoc debian/changelog ChangeLog.debian
if use nls; then
local dir
for dir in "${WORKDIR}"/deb/usr/share/man/*; do
- [ -f "${dir}"/man1/realpath.1 ] || continue
+ [[ -f "${dir}"/man1/realpath.1 ]] || continue
newman "${dir}"/man1/realpath.1 realpath.${dir##*/}.1
done
fi