summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-06-17 01:07:41 +0200
committerLars Wendler <polynomial-c@gentoo.org>2022-06-17 01:07:47 +0200
commitf5296d73a7179526b8d737014bd8e68ece7e4aba (patch)
tree559abb24769315eb97373dd79edcb7d08d70ba07 /app-misc/reptyr/reptyr-0.9.0.ebuild
parentnet-misc/ntpsec: Stabilize 1.2.1-r6 amd64, #851978 (diff)
downloadgentoo-f5296d73a7179526b8d737014bd8e68ece7e4aba.tar.gz
gentoo-f5296d73a7179526b8d737014bd8e68ece7e4aba.tar.bz2
gentoo-f5296d73a7179526b8d737014bd8e68ece7e4aba.zip
app-misc/reptyr: Bump to version 0.9.0
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-misc/reptyr/reptyr-0.9.0.ebuild')
-rw-r--r--app-misc/reptyr/reptyr-0.9.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-misc/reptyr/reptyr-0.9.0.ebuild b/app-misc/reptyr/reptyr-0.9.0.ebuild
new file mode 100644
index 000000000000..d36f18cfc3bd
--- /dev/null
+++ b/app-misc/reptyr/reptyr-0.9.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 toolchain-funcs flag-o-matic vcs-snapshot
+
+DESCRIPTION="A utility to attach a running program to a new terminal"
+HOMEPAGE="https://github.com/nelhage/reptyr"
+SRC_URI="https://github.com/nelhage/${PN}/archive/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+RESTRICT="test"
+
+src_prepare() {
+ default
+ # respect CFLAGS
+ sed -i '/^override/d' Makefile || die
+}
+
+src_compile() {
+ append-cppflags -D_GNU_SOURCE
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}"/usr install
+ dodoc ChangeLog NOTES README.md
+ newbashcomp reptyr{.bash,}
+}