summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2018-07-17 11:00:07 +0200
committerJohannes Huber <johu@gentoo.org>2018-07-17 11:00:25 +0200
commit56382f3de98199ce0c4498c75da52af353192814 (patch)
treef4021a0556d1390e55b04bd6fed53a15a58d82e6 /app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild
parentwww-apps/nextcloud: drop old, security bug #660918 (diff)
downloadgentoo-56382f3de98199ce0c4498c75da52af353192814.tar.gz
gentoo-56382f3de98199ce0c4498c75da52af353192814.tar.bz2
gentoo-56382f3de98199ce0c4498c75da52af353192814.zip
app-misc/screenfetch: EAPI 7
Package-Manager: Portage-2.3.43, Repoman-2.3.10
Diffstat (limited to 'app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild20
1 files changed, 10 insertions, 10 deletions
diff --git a/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild b/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild
index 673c98a4a09f..f2c6bb16d7d5 100644
--- a/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild
+++ b/app-misc/screenfetch/screenfetch-3.8.0-r1.ebuild
@@ -1,13 +1,22 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
MY_PN="${PN/f/F}"
DESCRIPTION="Bash Screenshot Information Tool"
HOMEPAGE="https://github.com/KittyKatt/screenFetch"
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+ SRC_URI="${HOMEPAGE}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
+
LICENSE="GPL-3"
SLOT="0"
IUSE="curl X"
@@ -20,15 +29,6 @@ RDEPEND="
x11-apps/xdpyinfo
)"
-if [[ ${PV} == *9999 ]] ; then
- EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch.git"
- inherit git-r3
-else
- KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
- SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV}"
-fi
-
src_install() {
newbin ${PN}-dev ${PN}
einstalldocs