summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCraig Andrews <candrews@integralblue.com>2017-03-10 12:37:47 -0500
committerDavid Seifert <soap@gentoo.org>2017-03-23 21:44:55 +0100
commit1461d3584a3d6a25e55019fab65b709a1039e16f (patch)
tree6ffe34fcbe3ef99ff55f6878300112ceb3d7748a /app-misc/screenfetch/screenfetch-9999.ebuild
parentgames-mud/tf: Remove old (diff)
downloadgentoo-1461d3584a3d6a25e55019fab65b709a1039e16f.tar.gz
gentoo-1461d3584a3d6a25e55019fab65b709a1039e16f.tar.bz2
gentoo-1461d3584a3d6a25e55019fab65b709a1039e16f.zip
app-misc/screenfetch: version bump to 3.8.0
Update -9999 to be in sync with the release version Add curl use flag Make the X use flag include X dependencies Gentoo-bug: 605698 Package-Manager: Portage-2.3.4, Repoman-2.3.2 Closes: https://github.com/gentoo/gentoo/pull/4176
Diffstat (limited to 'app-misc/screenfetch/screenfetch-9999.ebuild')
-rw-r--r--app-misc/screenfetch/screenfetch-9999.ebuild33
1 files changed, 20 insertions, 13 deletions
diff --git a/app-misc/screenfetch/screenfetch-9999.ebuild b/app-misc/screenfetch/screenfetch-9999.ebuild
index d0707b7e781b..cad0e56fc2fb 100644
--- a/app-misc/screenfetch/screenfetch-9999.ebuild
+++ b/app-misc/screenfetch/screenfetch-9999.ebuild
@@ -1,28 +1,35 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit eutils git-r3
-
MY_PN="${PN/f/F}"
DESCRIPTION="Bash Screenshot Information Tool"
HOMEPAGE="https://github.com/KittyKatt/screenFetch"
-EGIT_REPO_URI="https://github.com/KittyKatt/screenFetch"
LICENSE="GPL-3"
SLOT="0"
-KEYWORDS=""
-IUSE="X"
+IUSE="curl X"
+
+DEPEND=""
+RDEPEND="
+ curl? ( net-misc/curl )
+ X? (
+ media-gfx/scrot
+ x11-apps/xdpyinfo
+ )"
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="git://github.com/KittyKatt/screenFetch.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+ SRC_URI="https://github.com/KittyKatt/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/${MY_PN}-${PV}"
+fi
src_install() {
newbin ${PN}-dev ${PN}
- dodoc CHANGELOG README.mkdn TODO
-}
-
-pkg_postinst() {
- optfeature "resoluton detection" x11-apps/xdpyinfo
- optfeature "screenshot taking" media-gfx/scrot
- optfeature "screenshot uploading" net-misc/curl
+ einstalldocs
}