summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-10-16 15:58:34 +0200
committerDavid Seifert <soap@gentoo.org>2021-10-16 15:58:34 +0200
commitdb59f2bc06cf445ea11088c033a179ab246ce726 (patch)
tree3b8cc7126f1c8fbf0b1cfcd4a38cb94c21bb6bdc /app-misc/srm/srm-1.2.15.ebuild
parentapp-misc/kanatest: fix -Wformat-security (diff)
downloadgentoo-db59f2bc06cf445ea11088c033a179ab246ce726.tar.gz
gentoo-db59f2bc06cf445ea11088c033a179ab246ce726.tar.bz2
gentoo-db59f2bc06cf445ea11088c033a179ab246ce726.zip
app-misc/srm: port to EAPI 8
Closes: https://bugs.gentoo.org/714026 Closes: https://bugs.gentoo.org/722320 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'app-misc/srm/srm-1.2.15.ebuild')
-rw-r--r--app-misc/srm/srm-1.2.15.ebuild19
1 files changed, 11 insertions, 8 deletions
diff --git a/app-misc/srm/srm-1.2.15.ebuild b/app-misc/srm/srm-1.2.15.ebuild
index a086636c2048..cedaa944e3f7 100644
--- a/app-misc/srm/srm-1.2.15.ebuild
+++ b/app-misc/srm/srm-1.2.15.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=8
-inherit autotools epatch
+inherit autotools flag-o-matic
DESCRIPTION="A command-line compatible rm which destroys file contents before unlinking"
HOMEPAGE="https://sourceforge.net/projects/srm/"
@@ -14,23 +14,26 @@ SLOT="0"
KEYWORDS="amd64 ppc ~ppc64 x86"
IUSE="debug"
-DEPEND="!app-misc/secure-delete
- sys-kernel/linux-headers
-"
+DEPEND="sys-kernel/linux-headers"
-DOCS=( AUTHORS ChangeLog NEWS README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.2.15-cflags.patch
+ "${FILESDIR}"/${PN}-1.2.15-musl.patch
+)
src_prepare() {
- epatch "${FILESDIR}/${PN}-1.2.15-cflags.patch"
+ default
eautoreconf
}
src_configure() {
+ # enable the sighandler_t decl on glibc and musl
+ append-cppflags -D_GNU_SOURCE
econf $(use_enable debug)
}
pkg_postinst() {
ewarn "Please note that srm will not work as expected with any journaled file"
ewarn "system (e.g., reiserfs, ext3)."
- ewarn "See: ${EROOT%/}/usr/share/doc/${PF}/README"
+ ewarn "See: ${EROOT}/usr/share/doc/${PF}/README"
}