summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/symlinks
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/symlinks')
-rw-r--r--app-misc/symlinks/Manifest1
-rw-r--r--app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch11
-rw-r--r--app-misc/symlinks/metadata.xml12
-rw-r--r--app-misc/symlinks/symlinks-1.4-r2.ebuild35
-rw-r--r--app-misc/symlinks/symlinks-1.4.ebuild28
5 files changed, 87 insertions, 0 deletions
diff --git a/app-misc/symlinks/Manifest b/app-misc/symlinks/Manifest
new file mode 100644
index 000000000000..d6b0c112efee
--- /dev/null
+++ b/app-misc/symlinks/Manifest
@@ -0,0 +1 @@
+DIST symlinks-1.4.tar.gz 4942 SHA256 b0bb689dd0a2c46d9a7dd111b053707aba7b9cf29c4f0bad32984b14bdbe0399 SHA512 d1efb1ca553cc9eb95f1d113e453acd22c9f0964eacec985c85c125de23ae9d636b9ced182c2673f455e5d897ad15a978a424170fce767ccc492443eac7f972f WHIRLPOOL 4161680c79b58aac890fbc60e48e1659b253a88c67ea8684fd3d2efc216d20c74b0bfb770a1c74cab49a3e9753be484f350f9726acfdcafcd76260f579348da8
diff --git a/app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch b/app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch
new file mode 100644
index 000000000000..a5e9b0d6314a
--- /dev/null
+++ b/app-misc/symlinks/files/symlinks-1.2-fix-implicit-declaration.patch
@@ -0,0 +1,11 @@
+diff -Naur symlinks-1.2-orig/symlinks.c symlinks-1.2/symlinks.c
+--- symlinks-1.2-orig/symlinks.c 1996-10-15 15:02:57.000000000 -0400
++++ symlinks-1.2/symlinks.c 2007-12-10 18:08:43.000000000 -0500
+@@ -3,6 +3,7 @@
+ #define _POSIX_SOURCE
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <malloc.h>
+ #include <string.h>
+ #include <fcntl.h>
diff --git a/app-misc/symlinks/metadata.xml b/app-misc/symlinks/metadata.xml
new file mode 100644
index 000000000000..8cefae8361fc
--- /dev/null
+++ b/app-misc/symlinks/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>shell-tools</herd>
+ <longdescription lang="en">
+ Symlinks scans directories for symbolic links and lists them on stdout.
+ Each link is prefixed with a classification of relative, absolute,
+ dangling, messy, lengthy or other_fs. Symlinks can also convert
+ absolute links (within the same filesystem) to relative links and can
+ delete messy and dangling links.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-misc/symlinks/symlinks-1.4-r2.ebuild b/app-misc/symlinks/symlinks-1.4-r2.ebuild
new file mode 100644
index 000000000000..752ec8e05c0c
--- /dev/null
+++ b/app-misc/symlinks/symlinks-1.4-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Scans for and fixes broken or messy symlinks"
+HOMEPAGE="http://www.ibiblio.org/pub/linux/utils/file/"
+SRC_URI="http://www.ibiblio.org/pub/linux/utils/file/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="static"
+
+src_prepare() {
+ # could be useful if being used to repair
+ # symlinks that are preventing shared libraries from
+ # functioning.
+ use static && append-flags -static
+ append-lfs-flags
+ sed 's:-O2::g' -i Makefile || die
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CPPFLAGS} ${CFLAGS} ${LDFLAGS}"
+}
+
+src_install() {
+ dobin symlinks
+ doman symlinks.8
+ dodoc symlinks.lsm
+}
diff --git a/app-misc/symlinks/symlinks-1.4.ebuild b/app-misc/symlinks/symlinks-1.4.ebuild
new file mode 100644
index 000000000000..c30aaedb3ddf
--- /dev/null
+++ b/app-misc/symlinks/symlinks-1.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic eutils toolchain-funcs
+
+DESCRIPTION="Scans for and fixes broken or messy symlinks"
+HOMEPAGE="http://www.ibiblio.org/pub/linux/utils/file/"
+SRC_URI="http://www.ibiblio.org/pub/linux/utils/file/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 sparc x86"
+IUSE="static"
+
+src_compile() {
+ # could be useful if being used to repair
+ # symlinks that are preventing shared libraries from
+ # functioning.
+ use static && append-flags -static
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS} ${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin symlinks || die
+ doman symlinks.8 || die
+ dodoc symlinks.lsm || die
+}