summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Denoncin <ddenoncin@gmail.com>2021-06-01 00:21:55 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-06-17 09:49:16 +0300
commitf1a75e5104eabe3925c0b86d15d65e20d5bb4fd0 (patch)
tree0e2409312e788f5216aae3ffe5437ff5cc47a413 /app-misc/timew
parentdev-db/sqlitebrowser: version bump to 3.12.2 (diff)
downloadgentoo-f1a75e5104eabe3925c0b86d15d65e20d5bb4fd0.tar.gz
gentoo-f1a75e5104eabe3925c0b86d15d65e20d5bb4fd0.tar.bz2
gentoo-f1a75e5104eabe3925c0b86d15d65e20d5bb4fd0.zip
app-misc/timew: vbump 1.4.3 and add tests
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: David Denoncin <ddenoncin@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/21068 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-misc/timew')
-rw-r--r--app-misc/timew/Manifest1
-rw-r--r--app-misc/timew/timew-1.4.3.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/app-misc/timew/Manifest b/app-misc/timew/Manifest
index c8b08a9bf02c..0bd242c5a8db 100644
--- a/app-misc/timew/Manifest
+++ b/app-misc/timew/Manifest
@@ -1 +1,2 @@
DIST timew-1.4.2.tar.gz 1316841 BLAKE2B c451f37aeb32e999fe2cdca2eb5f234c7424b76f489324d5723a3649da37f53f5094989bdf8d5c2d27f5daa0d75c72ec4a01e3c19b8b064f28e4db82587498b9 SHA512 fe4c3def6b2cd78793dd97a38a61497b3910cd87a3315f826c64893b96a998bf30363f0df1892b74b718d03a279d51c1a636739225e101c5c126794e434076f0
+DIST timew-1.4.3.tar.gz 3188726 BLAKE2B ded92b2ba801023e7f6bc59c0fc17ce069c8279ee92f39280c50dabec0a2425b8612f73edf7842abdbb0b21772244eda325512070c091f32d17ff69cfcd844fa SHA512 89c98ad19d3a5ab5d4e02819d79e553cca4e93da99ec02bbf845b96b421cd084f6786de160e90c97854b50da49448472e9a4c7d23e75c8a93ecd67dda768b24a
diff --git a/app-misc/timew/timew-1.4.3.ebuild b/app-misc/timew/timew-1.4.3.ebuild
new file mode 100644
index 000000000000..e037edcce536
--- /dev/null
+++ b/app-misc/timew/timew-1.4.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Tracks your time from the command line, and generates reports"
+HOMEPAGE="https://timewarrior.net"
+SRC_URI="https://github.com/GothenburgBitFactory/timewarrior/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ mycmakeargs=(
+ -DTIMEW_DOCDIR=share/doc/${PF}
+ )
+
+ cmake_src_configure
+}
+
+src_test() {
+ cd "${WORKDIR}"/"${P}"_build || die
+
+ eninja test
+}
+
+src_install() {
+ cmake_src_install
+
+ dodoc -r ext
+ docompress -x /usr/share/doc/${PF}/ext/{on-modify.timewarrior,README}
+}
+
+pkg_postinst() {
+ elog "To integrate timewarrior with taskwarrior, issue the following commands:"
+ elog "cp /usr/share/doc/${PF}/ext/on-modify.timewarrior ~/.task/hooks/"
+ elog "chmod +x ~/.task/hooks/on-modify.timewarrior"
+ elog "see https://timewarrior.net/docs/taskwarrior.html"
+}