summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-misc/tkpasman
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-misc/tkpasman')
-rw-r--r--app-misc/tkpasman/Manifest1
-rw-r--r--app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch22
-rw-r--r--app-misc/tkpasman/metadata.xml7
-rw-r--r--app-misc/tkpasman/tkpasman-2.2b.ebuild40
4 files changed, 70 insertions, 0 deletions
diff --git a/app-misc/tkpasman/Manifest b/app-misc/tkpasman/Manifest
new file mode 100644
index 000000000000..e07de0a68622
--- /dev/null
+++ b/app-misc/tkpasman/Manifest
@@ -0,0 +1 @@
+DIST TkPasMan-2.2b.tar.gz 31365 SHA256 c6f99905a2395e251d92e2f9cbda486492895bb969cb5693bfeffdb849fbd4fc SHA512 ca74ed6a5989c21b266ff4bed00963d46eb05e1a7a0822dceeae5c87bcbb7bf36a775eedf86244fa1121008a6df59fa38003e07e8cb6e4ddf98c895b61f24f12 WHIRLPOOL f7a49837a8fe64a28961f1c494d83b3374f479878e85bdc0b442350dfcfb387795cae19eeedfd7aa11f2a985970d1803c27de131456470cc5403c344a996ce4b
diff --git a/app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch b/app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch
new file mode 100644
index 000000000000..d52d5129b7c7
--- /dev/null
+++ b/app-misc/tkpasman/files/tkpasman-2.2a-gentoo.patch
@@ -0,0 +1,22 @@
+--- build.sh 2005-01-01 19:18:44.290385166 +0000
++++ build.sh 2005-01-01 19:22:45.846161383 +0000
+@@ -44,8 +44,8 @@
+ #
+ # Try to find wish8.3, tclsh8.3 and openssl
+ #
+-WISH=`FIND "$WISH" "" wish8.4 wish8.3 wish`
+-TCLSH=`FIND "$TCLSH" "" tclsh8.4 tclsh8.3 tclsh`
++WISH=`FIND "$WISH" "" wish wish8.4 wish8.3`
++TCLSH=`FIND "$TCLSH" "" tclsh tclsh8.4 tclsh8.3`
+ OPENSSL=`FIND "$OPENSSL" "$OPENSSL_SEARCH_PATH" openssl ssl`
+
+ #
+@@ -88,7 +88,7 @@
+ if test "$USE_OPENSSL" = "true" -a -x "$OPENSSL"
+ then
+ echo "Found OpenSSL program: $OPENSSL"
+- ENC=`$OPENSSL list-cipher-commands|sort|egrep "^($ENC)\$"|head -1`
++ ENC=`$OPENSSL list-cipher-commands|sort|egrep "^($ENC)\$"|head -n 1`
+ if test -z "$ENC"
+ then
+ echo "Could not find a suitable encryption algorithm."
diff --git a/app-misc/tkpasman/metadata.xml b/app-misc/tkpasman/metadata.xml
new file mode 100644
index 000000000000..1470e032181b
--- /dev/null
+++ b/app-misc/tkpasman/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-misc/tkpasman/tkpasman-2.2b.ebuild b/app-misc/tkpasman/tkpasman-2.2b.ebuild
new file mode 100644
index 000000000000..7e4b709cf6ef
--- /dev/null
+++ b/app-misc/tkpasman/tkpasman-2.2b.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+MY_P="TkPasMan-${PV}"
+
+DESCRIPTION="A useful and reliable personal password manager, written in Tcl/Tk"
+HOMEPAGE="http://www.xs4all.nl/~wbsoft/linux/tkpasman.html"
+SRC_URI="http://www.xs4all.nl/~wbsoft/linux/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="ssl"
+
+DEPEND="
+ >=dev-lang/tcl-8.3:0=
+ >=dev-lang/tk-8.3:0="
+RDEPEND="${DEPEND}
+ ssl? ( dev-libs/openssl )
+ "
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-2.2a-gentoo.patch
+
+ if use ssl; then
+ sed -i "s:^USE_OPENSSL=true:USE_OPENSSL=false:g" config || die
+ fi
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc README ChangeLog TODO WARNING INSTALL
+}